1

I have a 3 years old LG Nexus-4, I have tried multicore cpu controller pro and some cardboard/VR apps (google cardboard, fulldive, etc..) recently & I have faced some rare random restart for 4-5 days. (that was not too much, its like 2 times restart a day)

Now I am facing a very wired issue. My phone runs fine on AC/charging status, but as soon as I go on battery (disconnect AC/charging) mobile just goes off or reboot and does not boot at all :(

Another weirdest thing is it works fine (on battery as well) on bootloader & recovery clockwork (6.0.4.7-mako.img) adb & fastboot command works & even touches works fine on TWRP 2.7 and battery status reports properly 100% to 1% (till it dies after full battery drain & it takes for 3-5 hours), so battery is not a real problem :|

The following things are already tired and result are mentioned respectively.

  1. Uninstalled all the recently installed app and cleared all settings from mutlicore cpu controller pro

  2. Updated OS to 3rd party marshmallow, Tried a 6.0 Android M for nexus 4 from xda forum.

  3. Rolled back to factory image - Android 4.4 (occam-krt16s)

  4. Updated OS from factory image - Android 4.4.4 (occam-ktu84p)

  5. Tried TWRP 2.8, 3.0 as well

  6. Tried debugging with adb :

C:\Program Files (x86)\Minimal ADB and Fastboot>adb bugreport

/sbin/sh: bugreport: not found

C:\Program Files (x86)\Minimal ADB and Fastboot>adb logcat -v time

/sbin/sh: exec: line 1: logcat: not found

  1. Tried to boot to safe mode. works fine again only on AC/Charging. :(

Results: No change at all :(

It would be very grateful, if anyone could give some information how to find the root cause or a solution/fix for this.

  • 2
    did you reflash the kernel (boot.img) somewhere during that process? – Valentin Kuhn Mar 13 '16 at 18:26
  • 2
    If you have done a full factory flash (flash-all.xx) of LMY48T factory image, and this still occurs, that indicates a hardware failure. Since the only real replaceable hardware at a reasonable cost in this device (that would relate to this functionality) is the battery, I would start with replacing the battery. There could be a problem in the battery electronics that only presents itself to the OS when there is no charge coming in, and recovery doesn't care/recognize it. If the problem still occurs, it is likely a mainboard issue and the device should be replaced. – acejavelin Mar 13 '16 at 18:32
  • @ValentinKuhn: Yes, this happens during flash-all.bat run process. – Amol M Kulkarni Mar 14 '16 at 7:09
  • in this case I'd do as @acejavelin suggested – Valentin Kuhn Mar 14 '16 at 7:17

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.