4

My Google Now for some time ago stopped speaking and executing commands.

When I do a command like 'set timer for ten minutes from now' it only searches Google for the text. Same for 'play Jimi Hendrix on YouTube'.

This began to happen when I logged in to Google Now and accepted the new terms.

When I say 'what's the Weather' it shows, but don't speaks out loud. I think that the fact of this working has to be with the google search itself and not the Google Now app.

Language is correctly set for english, and "Speech output" is set to on.

I have seem many other people with this issue googling for this, but yet no real fix.

Android is version 4.2.2 and Google Now is version 5.9.33.16.arm.

EDIT: I have used Tasker + AutoVoice but don't believe this is the problem, because it begin right after I login to Google Now and accept the license; AutoVoice commands in Google Now are not working as well.

  • 1
    I would try disabling AutoVoice, as it can (and often will) mess with Google Now's functions. It has happened several times for me. – Michelfrancis Bustillos Mar 17 '16 at 20:32
  • I've deleted it and even Tasker. I also think it messes up with Google Now. – Iacchus Mar 17 '16 at 20:35
  • 1
    Have you tried resetting and/or reinstalling Google Now? – Michelfrancis Bustillos Mar 17 '16 at 20:37
  • Yes, even reflashed the same Android. – Iacchus Mar 18 '16 at 11:51
  • 1
    Did you try to clear data for the problematic apps and doing a re-login of google account into the phone? – Rahul Bali Mar 21 '16 at 20:07
0

I am the author of the OP. Reflashing another Android version (currently using Lollipop 5.1.1) "solved" the issue.

  • I noticed also that services running as Accessibility makes it even to stop recognizing Voice commands. – Iacchus Apr 26 '16 at 15:50
0

Had the same issue (several times). Latest attempt to fix is to force stop the Google app, disable it. Then enable it again and check all settings.

It worked on my Oneplus 3T, running 7.0. :D

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.