1

My phone has stuck in a bootloop when it rebooted after installing a font using HiFont. I have tried HiFont many times, it works well. It is for the first time it happened. The phone boots up and shows the whole animation but gets stuck on the last frame. Please suggest me a good solution.

  • Android version: 4.1.1 Jelly Bean
  • Mobile manufacturer: Micromax
  • Rooted
  • Model: Bolt A61

Hard reset and wipe cache partition are not working. Typing ls in adb shell inside the /system/font gives the following output

  • 2
    Of course they don't. The fonts are contained within the System partition. Only reinstalling the firmware will fix this issue. – Death Mask Salesman Mar 15 '16 at 1:30
  • 1
    If I recall correctly, the system fonts are comprised by the Roboto family. For this motive, I recommend you to obtain the content of the /system/fonts folder via ls, issued from adb, and to update your question with the output of ls. This way, we could start to know how HiFont works, and, thus, conceive a way to solve the issue. The hard way would be to download one firmware suited for your phone, move it to the SD card (or the internal SD via adb), and flash it via recovery. – Death Mask Salesman Mar 15 '16 at 2:04
  • 1
    @AaronGillion It may work, but I recall that these "font customizer" apps often replace the Roboto family with the font family chosen by the user, and then rename it to match the Roboto names. Such approach wouldn't work, if that's the case with HiFont. – Death Mask Salesman Mar 21 '16 at 13:54
  • 1
    @Aman Glad to hear that you were able to solve the issue. – Death Mask Salesman Mar 22 '16 at 14:17
  • 1
    @DeathMaskSalesman Yes, that's right. But you were also somewhere involved in my success. No more arguments, just a big Thanks. You are great. Keep it up. – Aman Mar 22 '16 at 14:30
2

Since you have access to ADB with root, you can easily remove the font you installed using this command:

rm /system/fonts/xxxxx.TTF

If you don't have the slightest clue which fonts were yours, you can actually sort ls output by date modified, as so:

ls -tr

...which will show the most recent fonts at top, given the modified dates are correct.

If your most recent font is of the Roboto family, that means your customizer app replaced the default font! You'll have to write down the exact filename, remove it, and cp another font (eg. Arial) and rename it to the same filename. Of course, none of this will be needed if you have a device backup. Just copy the originals.

Hope this solves your problem!

  • I am about to try it. – Aman Mar 21 '16 at 14:01
  • How to copy the fonts from my computer(S:\fonts*.ttf) to the /system/fonts using adb. – Aman Mar 21 '16 at 14:14
  • adb push s:\RobotoLight.ttf then cp /sdcard/Roboto.ttf /system/fonts/Roboto.ttf – Aaron Gillion Mar 21 '16 at 14:17
  • 1
    You have to exit the shell first, so there's no # or $ when you type. Or just open a new command prompt window. Try adding the destination /sdcard to the end of it. – Aaron Gillion Mar 21 '16 at 15:12
  • 1
    Thanks. It worked. You are great. Thanks. Thanks. Thanks. – Aman Mar 22 '16 at 4:50

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.