3

I have a Samsung Galaxy S6. This year I'm doing an experiment wherein I do not participate in Daylight Saving Time (DST). However, my phone automatically adjusts itself for DST.

How do I disable this? Is there any way too stop my phone's clock from adding or removing an hour twice a year?

  • Umm, turn off "automatic date & time" and "automatic time zone" on your settings? Should be available on most Android devices. Alternatively, you need to choose another timezone that doesn't observe DST. (don't forget to adjust your alarm manually). – Andrew T. Mar 16 '16 at 2:37
  • @AndrewT. I still want it to automatically set the date and time do it's accurate, just without daylight savings time. – Supuhstar Mar 16 '16 at 2:40
4

Android uses tzdata (IANA Time Zone Database) to store time zone data, and Daylight Saving Time (DST) information is included in it. The data tells if DST is observed from what date/time to what date/time on a given time zone. Thus, you can't really disable the DST if you're using a time zone that observes DST.

Therefore, to "disable" the DST, you have to choose a time zone that doesn't observe DST, and has same offset with your current time zone. (You can try to find it from Wikipedia's List of tz database time zones)

Example:

You also have to turn off Automatic time zone option to prevent it being changed back to the network provided time zone.

|improve this answer|||||
  • 1
    There's a possibility that the offset you're currently use doesn't have other time zones that don't/do observe DST. In this case, I'm not sure there's a solution, other than trying to create a new time zone data on tzdata and use it. It should be possible, but I haven't researched it. – Andrew T. Mar 16 '16 at 3:49
  • So even when I turn off automatic time zone (and manually change from Eastern to Central) it will still change for daylight savings time? – Supuhstar Mar 17 '16 at 12:15
  • 1
    @Supuhstar Central Time (CST/CDT) observe DST, so you can't use them. You must find another time zone that has offset GMT-06:00 and doesn't observe DST... which is Galapagos Islands, Ecuador (if it's available...) – Andrew T. Mar 17 '16 at 12:23
  • @Supuhstar I updated my answer to add the link to list of tz database time zones. Try it by sorting the UTC offset and find the one with same UTC DST offset. – Andrew T. Mar 17 '16 at 12:33
  • 1
    @beeshyams hmm, I have read that question, and I'm actually still not sure about the fix. AFAIK, unlike this question, the OP still wants to have DST applied for daily purpose, but the issue is with GPS time itself (as you have found on Strava forum). I don't know if the issue is with how the OS handling the GPS time ignoring the DST, or the apps themselves, or even the GPS sources themselves (if possible, but who know)... – Andrew T. Nov 24 '18 at 4:33
1

Try this app: TimeZone Changer

I just spent several hours fighting with Android's time zones. It wouldn't even let me select a UTC+0 city that doesn't change between winter/summer time (e.g. > Reykjavik).

After searching and searching I came across Google's bug forum, where they recommends TimeZone Changer app.

Source: Google's bug tracker forum

Hope you will find this useful.

|improve this answer|||||
0

I have Galaxy Note 4 with Android 5.01 and the timezone of Cairo was +3 GMT which is wrong. When I use Automatic timezone and automatic date and time from network results in two different times one of widget and the other of main screen. Finally I found a utility which repair the timezone of my phone (TimeZone Fixer (ROOT)) https://play.google.com/store/apps/details?id=com.force.timezonefixer just Try may help you.

|improve this answer|||||

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.