I am very happy with my Galaxy S, which I have had for about a year now. Recently I noticed that some of the installed applications seem to lose data. Because I do not know the file system nor the inner working of an Android device, I will give the specific apps in the hope that someone recognizes this or at least can tell me something to try.

  1. The first program I noticed was Friend Caster. This is a (very good) Facebook client which worked fine for some weeks. But now I have to, at least once a day, re-enter my user ID and password. The technical staff helped with some things to try (related to the Facebook integration), but nothing helps.

  2. The second program I noticed was Business Calendar Free. Every once in a while (and I really can't put my finger on why) this program starts up as if it is just installed - i.e. it produces the start help screen, and I lose the settings I chose (f.i. the chosen colours for Saturday and Sunday). Although the installed and active calendars are kept. Also, the widgets of this program, stop updating themselves, which is rather useless for a calendar widget, of course :)

I have lots of other programs installed, and all of those seem to work correctly. None of them has an obvious function which could cause this.

Samsung Galaxy S - GT-I9000 - Firmware 2.2.1 - Kernel - phone is not rooted

The problem can be specific to those two programs, of course, so I also installed both of them on my son's Galaxy S, on my wife's LG, and on my Archos 101 tablet. None of these phones present the same problem.


I have upgraded my Android version to version 2.3.3, but this has not solved the problem.

Any help would be greatly appreciated.


I received the following answer from the nice guys from the Business Calendar support. Can anybody verify this (or knows a solution to the problem):

This is a well known problem on some Samsung devices, since the update of Android version 2.2.1. The settings of some apps are not saved permanently. Once this problem occured, this will happen again and again.

As the problem seems to be caused by a bug in Samsung's version of the Android OS I am afraid to say that we can't do anything against it. We hope that Samsung is about to fix the reason of this in the future. Maybe you can contact the Samsung support, that they hopefully accelerate working on that issue.

So unfortunately your device is affected by this problem. Some people told us that a factory reset helps them out of this really annoying problem, but I won't guarantee for anything. That's up to you.

  • Is there no 2.3 update for you (carrier branded ?) Galaxy S?
    – Flow
    Sep 30, 2011 at 14:56
  • I think there is, yes. I will install it and report back.
    – Edelcom
    Sep 30, 2011 at 15:23
  • Hmm, do you install any of this stuff on an SD card?
    – Chance
    Oct 10, 2011 at 23:14
  • @Chance AFAIK Samsung Galaxy S stil has a problem with SD cards in so far that you cannot move applications to the SD card (although programs can use it for writing data). Upgrading my Galaxy from 2.1 to 2.2 to 2.3 did not solve this problem (and I don't want to root my phone to solve it myself - another question here on this forum explains how). Maybe that can be the problem , although my son who also has a Galaxy S does not have this problem. Problem is, I don't know where to start looking for a solution.
    – Edelcom
    Oct 11, 2011 at 6:53

2 Answers 2


It may actually be a Samsung problem. Here's a similar problem report (app on Samsung becomes forgetful) with DropBox: http://forums.dropbox.com/topic.php?id=37207

The DropBox folks claim they fixed it (though perhaps they just worked around it). I couldn't find any details, so it may not be the same underlying mechanism as the apps you're having problems with.

Assuming the apps in question store the login data in an sqlite database internally, here's a SO question about a similar problem: https://stackoverflow.com/questions/5886019/android-application-samsung-galaxy-tab-2-2-does-not-sometimes-write-to-the. Sadly, it is currently unanswered.

The Samsung developer website does not have any mention of sqlite or persistence problems that I could find. (But there isn't a whole lot there.)


I can't answer why this is happening to your Galaxy S. Mine works just fine and I'm also able to transfer apps to the SD. But here is how I would approach the problem:

  • Look in the system log, either via adb or an app. Maybe there is a hint about what's going on.
  • Try installing a custom rom. I have heard that cyanogen mod has pretty good support for the SGS. This will likely also change the filesystem to ext3/4.

All in all it sounds like and hardware problem of the flash storage. The system log will maybe reveal some unreadable sectors.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .