5

I have an Android 6, Samsung S6 smartphone and today I bought a tram ticket via SMS. Before sending, a warning popped up asking if I wanted to grant the Messages app the permission "SMS Services that cost you money". I assume this was because the SMS ("Premium SMS") is overcharged (by the price of the ticket), since the app never asked for this permission before sending a SMS.

I replied Yes, since it was a legitimate purchase, but I was in a hurry and involuntarily I ticked the option "remember my choice".

Now I would like that Android keeps asking me before sending Premium SMSs, since it's a security risk, but I couldn't find a setting to disable this option. Is this possible? Or the only way is to hard reset my phone and reconfigure it from scratch? I can't believe Android doesn't offer this option.

  • Which messaging app is it? Does any relevant permission shows up in Settings -> Applications/Apps -> your messaging app -> Permissions? – Firelord Mar 18 '16 at 21:31
  • It's the standard Messages app, and the only relevant permission is to send and receive SMS messages. – dr01 Mar 18 '16 at 21:38
  • 1
    It appears that there used to be an option to revoke that permission which is not available anymore in Android M, once granted. Related discussion. – Firelord Mar 18 '16 at 21:44
  • Thanks. I found the same exact page while looking for a solution. And here's a related question, but the accepted answer doesn't work: android.stackexchange.com/questions/125939/… – dr01 Mar 18 '16 at 21:49
  • I wonder if this would be an accessible preference to other apps... if so, someone (I'm probably not good enough) could write an app to fix this... I think it would be a shared preference. Did anyone try clearing the cache? – seadoggie01 Aug 11 '16 at 18:00
4

You can choose another setting by going into Settings > Applications > Applications Manager > More (top right) > Show System Apps > Message Service (rather than Messages) > Tap 'Send Premium SMS' > Select Ask, Never Allow or Always Allow.

On more recent versions of Android (Nougat V7) the setting is at Settings > Apps > Application Manager > More (top right) > Special Access > Use Premium SMS services (may be listed as Use Premium text message services) > Select Ask, Never Allow or Always Allow.

screenshot of Message service app info

  • On which Android version and device did you test your answer upon? I'm asking in response to this comment of mine. – Firelord May 2 '16 at 14:36
  • On my Android (6.0.1) it just says "No permissions". There's no option "Send Premium Text Message". – dr01 May 2 '16 at 14:49
  • 2
    I'm running 6.0.1 on the S7 Edge, but my bad the instructions were slightly incorrect. Once you click into the Message Service app the option will show there - i.imgbox.com/xfjn8zwk.png – armybike May 2 '16 at 15:06
  • Did this manage to resolve the issue dr01 and Firelord? – armybike May 3 '16 at 6:17
  • 1
    I run Android 6.0.1 on a S6 and there's no option "Send premium SMS", but I'm glad to see this issue was solved in a newer version. Granting +1 and marking this as best answer. – dr01 May 5 '16 at 17:21
2

Well, bad news: It appears to be another of these annoying, huge Android bugs for which there's no solution yet.

The only workaround is to use another app for sending SMS, or to hard reset the phone.

From the discussion linked in the comments:

(...) the particular drop-down setting - for premium sms - you could toggle through back in an app's permissions in previous Android versions starting from 4.2. The case would arise if when using an app that required to send an sms to a 5-digit number, the OS would present a 'You might get charged' warning popup, which would prompt you to Allow or Deny sending the sms. If you also checked the "Don't ask me again" option then this warning popup would not appear again next time.

A user could reset that checked option in Settings> Apps (or Application Manager), going to the permissions section of the specified app and uncheck the premium sms "lock"; With Marshmallow though, there does not seem to be a similar option back in app settings.

The permissions toggles only enable/disable the standard SMS sending and have no effect on a premium sms locked option when they are enabled, leading to a blocking scenario where if a user had selected the "Don't ask again" option initially, he/she will not be able to resend an sms from the particular app.

Even worse is the fact that uninstalling and re-installing the app does not reset that initial selection, rendering the sending of sms to 5-digit numbers impossible and beyond the user's control.

In the discussion you can read the comments of other users which have the opposite problem -- they replied "No" and ticked "Don't ask again", and now they are forbidden from sending Premium SMSs.

1

Happened the same thing with me. Solution: instal a 3rd party sms app, then make it the default message app. When I tried to send the premium sms it asked for permission again, and I allowed, now it works again in both apps, the 3rd party and the original one!

-1

theres an option to fix it go to applications then select the message app scroll down to the permission directly cost u money its clickable select ask.

-1

Only option till now in marshmallow android 6 if you are not able to send sms to short code numbers like 12345 or 123 or 1900 or when you try to send them your network towers goes away is to reset all app permissions, by going to settings-apps-click on the 3 dots on the top right corner in the screen and select reset all app preferences. Now send a short code message and allow it.

Not the answer you're looking for? Browse other questions tagged or ask your own question.