6

I messed up my phone trying to get open-gapps working on CM 13. I can't even get into my OS only into recovery mode. I tried flashing several CM-Versions, but that doesn't change much. I think the problem is, that my dalvik is corrupted. My data-partition is encrypted with a 3x3 pattern and TWRP can't decrypt it, so I can't wipe dalvik. I tried several variations of twrp decrypt, but they don't work. Now I am trying to flash cryptfs since I found a HowTo, which told me to use this commands:

setprop ro.crypto.state encrypted
vdc cryptfs checkpw 'pattern'
mount /dev/block/dm-0 /data

The problem is, that cryptfs is not installed. I tried to flash cryptfs, with a custom made zip-file, but it seems, the cryptfs-installation is also trying to write into /data and just aborts, since it can't mount it.

I really like to avoid making a factory-reset before getting my data out. Any suggestions? (I have a Sony Xperia M using nicky-cm)

  • What ROM with Android version did you use to encrypt data partition? Can you not just flash that ROM? – Firelord Mar 19 '16 at 16:55
  • 2
    The problem is not decrypting, when I start Android. I can decrypt, but after that, the loading screen gets stucked. Same with a CM 12-Rom. After the decryption, it seems to get in a loop(getting pretty hot over time, and using a lot of energy) – a.j. tawleed Mar 19 '16 at 16:59
  • "My data-partition is encrypted with a 3x3 pattern and TWRP can't decrypt it" -- can you shed some light on this? Which TWRP version are you using? Does it not provide a grid to provide pattern for decryption or is TWRP unable to process your pattern successfully? Have you tried this technique for decryption? Please list whatsoever variation of twrp decrypt you've tried because we can't know about things which you've not mentioned. – Firelord Mar 19 '16 at 17:03
  • 1
    I tried twrp-2.8.7.0-nicki and twrp-3.0.0-0-nicki. They don't provide a grid. I tried the technique you linked. It gives me 01040708. I tried that, I tried 1478, 02050809, 2589, 8523. – a.j. tawleed Mar 19 '16 at 17:23
  • First thing you should do is update to the latest [ 3.0.2-0-nicki ] TWRP twrp.me/devices/sonyxperiam.html This was what did the trick for me on my nexus – Albin K C Apr 29 '17 at 10:48
0

My data-partition is encrypted with a 3x3 pattern and TWRP can't decrypt it

This can be solved by considering the 3x3 grid as the numbers on the keypad. For Example, consider a pattern that looks like the uppercase L character.

↓ o o  |  1 2 3
↓ o o  |  4 5 6
↓ → →  |  7 8 9

here, your password would be 14789

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.