1

So I have a bricked gt-s5830i (galaxy ace) and when I try to flash it using odin I get this error:

<ID:0/003> Added!!
<OSM> Enter CS for MD5..
<OSM> Binary Check MD5.. Do not unplug the cable..
<OSM> Please wait..
<OSM> Checking MD5 finished Sucessfully..
<OSM> Leave CS..
<ID:0/003> Odin engine v(ID:3.1100)..
<ID:0/003> File analysis..
<ID:0/003> SetupConnection..
<ID:0/003> Initialzation..
<ID:0/003> Get PIT for mapping..
<ID:0/003> Firmware update start..
<ID:0/003> SingleDownload.
<ID:0/003> sbl.bin
<ID:0/003> NAND Write Start!! 
<ID:0/003> BcmCP.img
<ID:0/003> FAIL!
<ID:0/003> 
<ID:0/003> Complete(Write) operation failed.
<OSM> All threads completed. (succeed 0 / failed 1)
<ID:0/003> Removed!! 

It started boot looping after it randomly got stuck and I took out the battery since I couldn't do anything at all. This is the firmware I tried: http://www.sammobile.com/firmwares/download/37194/S5830IXXLK3_S5830IDBTLK1_DBT/ http://www.sammobile.com/firmwares/download/14913/S5830ZXXLK3_S5830ZDBTLK2_DBT/

Does anyone know what's causing this? This is also the first time I'm flashing a phone. The rom was downloaded from sammobile because the ones from samsung-updates seem to have broken downloads.

  • While waiting for answers on your question, please check these other questions with similar problems. Might find your solution there already. – Izzy Mar 20 '16 at 11:03
  • Maybe try this one instead, or try another country -- some of them seem to fail randomly. Someone had a similar issue here with a different device. I'd also suggest doing a battery pull, connecting the device, and then holding Volume Down while you reinsert the battery to get into Download Mode -- my old Vibrant always flashed more reliably when I did it that way. – Matthew Read Mar 20 '16 at 21:47
  • No luck, I got the exact same error message. – Florens Mar 21 '16 at 13:49
0

Use Odin 3.07. Also, make sure that you start odin as administrator. I had the same problem, and it worked for me. And prior to that, if it gets stuck in Setup Connection, just boot into "download mode" once again by pulling off the battery and re-inserting it.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.