2

I got a nexus 5 off of eBay, the seller said he had tried to root it and failed so I thought I would have a crack at it. I thought it would be an easy restore but I ran into a few problems:

Phone originally came with 6.0.1 installed. On android 5+ I could not access the standard recovery screen, and when I pressed power+volUp it just said formatting /data and would not move from that.

Rolled back to 4.4 and I got into the ususal recovery screen. Tried to do a factory reset, but it again stuck at formatting /data. I left it the entire night while I slept and it was still saying formatting /data. in the morning, nothing had changed. Trying to boot the phone normally just left it on the 4 circles startup screen.

I've tried doing a full flash of stock android with each seperate part manually. Also /data is unable to be mounted in any custom recovery, like it is corrupted or locked somehow. With the stock recovery, it cannot be detected by adb, but in cwm it can. However, it still doesn't allow access to /data.

Checking the /data folder in adb shell shows it's completely empty, and the same with system even after flashing and flashing again.

Can anyone advise me as to what might be the problem here?

  • "I've tried doing a full flash of stock android with each seperate part manually." -- you mean through fastboot, correct? Did you also upgrade the bootloader and radio meanwhile? When you flashed userdata image, what did the console output? Can you do a complete flash from fastboot one more time, then flash custom recovery, straightly boot into it and flash a compatible version of this kernel? That kernel would not cause full disk encryption at first boot of Android. Which custom recovery are you using? – Firelord Mar 22 '16 at 18:22
  • Yes through fastboot, and yes I also upgraded bootloader and radio at the same time. When flashing userdata, it would sometimes hang on the erasing 'userdata' command and I would have to reboot back into fast mode, where it would usually work fine the second time. I'll give this custom kernel a try right now! – Michael Nisbet Mar 23 '16 at 9:29
  • I was using clockworkmod 6.0.4.5 by the way, installing the kernel went smoothly, but upon restart it got to the google screen, then rebooted, and then booted itself into recovery again. It's now at least showing up in adb with the recovery tag, which it wasn't doing before – Michael Nisbet Mar 23 '16 at 9:43
  • Please use TWRP for the time being until you're done with troubleshooting. CWM is archaic now. – Firelord Mar 23 '16 at 13:46
  • 1
    I should mention that I originally tried twrp but when it booted into it, it attempted to access the /data partition and tried to mount it automatically on load, couldn't, and then restarted the phone. I was only using CWM because it didn't do that. – Michael Nisbet Mar 23 '16 at 14:03
0

I used this link to repair my /data directory:

http://forum.xda-developers.com/google-nexus-5/general/howto-repairing-corrupted-data-partition-t2577447

Fortunately I was able to boot into fastboot mode the usual way ( Volume down and power at the same time ) unfortunately TWRP kept looping after erring on the corrupted /data folder. I ended up replacing TWRP with "Philz Recovery Nexus 5" because it booted up normally. I then formatted the /data, /system, /cache directories. That fixed the /data directory error and corruption problem. I was able to load CM13 successfully after that. I had to use a OTG external USB drive to load Philz Recovery Nexus 5, CM13 and GApps. I hope this helps. I'm sticking with Philz Recovery Nexus 5. It fixed the problem!

  • Sorry for taking so long to get back to you, I forgot my account details. it fails to format the /data partition because it's unable to mount it, for whatever reason. – Michael Nisbet Apr 14 '16 at 15:42
  • I've just had another look at it, when trying to do a fastboot format it says it has filesystem type ' ' and is unable to do this. going to adb shell and trying to run mke2fs, results in a blinking cursor like it is trying to do something, but ultimately gets nowhere. – Michael Nisbet Apr 14 '16 at 15:49

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.