TL;DR: My wife's LG Nexus 5X has no issue charging with her LG charger or my Huawei charger. My Huawei Nexus 6P charges slowly with the Huawei charger but at full speed with the LG charger. Is there an explanation for this, and am I likely to run into more incompatibility (i.e. is it my phone or the charger)?

I have a Huawei Nexus 6P, and my wife has the LG Nexus 5X. When we first received them, we could use both either charger/cord combination and we would get the full 3A/5V ("charging rapidly" message appeared).

After a month or so, I noticed that my phone wasn't charging as quickly as I was used to, so I looked and saw it said "charging" but not "charging rapidly," which is what I get when I use a regular 2.1A charger. I looked and this was on the stock Huawei charger (that went with my 6P). I tested this setup with my wife's phone, and her phone said "charging rapidly."

At this point, I used her LG charger, and I once again got the "charging rapidly" message. I then tried both cables in both chargers, and it was only the original cable with the original charger that gave me a slow charge (charger and cable from Huawei). I did the experiment back-and-forth several times to make sure it wasn't just a fluke.

That was fine, I just switched the cables and was able to use either charger and get the "charging rapidly" message.

Eventually, though, I noticed the issue again, but this time with the cable from LG and the charger from Huawei. I tried switching the cables, but it didn't work.

So now my Huawei phone can't charge at full speed with the Huawei charger, but my wife's LG Nexus 5X can without issue. My 6P can charge at full speed with either cable using the 5X charger, but won't charge at full speed on the 6P charger with either cable. The 5X can charge at full speed using either charger with either cable.

I realize that I could just pitch the charger and maybe never have to think about it again, but that doesn't make any sense out the problem. I'm curious about the very specific progressive incompatibility, and I also don't want to deal with the same problem with another charger or set of chargers down the road.

So, is there any explanation for this hardware incompatibility? Also, is there a good chance this is a software issue? I noticed it after flashing either PureNexus or Chroma, but I'm sure it carried over after going back to PureNexus from Chroma, so I'm assuming it wouldn't be fixed by going back to the stock ROM.

1 Answer 1


Background Information

  1. From Nexus

    The Nexus 5X and Nexus 6P use USB Type-C for charging, so not all cables and chargers will work with these phones. We recommend using the charger that came with your Nexus.

  2. Also corroborated here for LG Nexus 5X

  3. Decent comparison of Type C Charging. Point to note is that current supplied can go upto 3A unlike conventional charging or Qualcomm Quick Charge 2.0

  4. When your device gets 3A it displays "charging rapidly" and when it gets 2.1A (conventional charging), it displays "charging". This can be verifed by using an app like Ampere

Analysis of symptoms described by you

  1. To start with Nexus 6P/ Nexus 5x in any charger/cord combination gave "charging rapidly"

  2. 6P Charger + 6P Cable on 6P → "charging"

  3. 6P Charger + 6p Cable on 5X → "charging rapidly"

  4. 5X Charger + 6P/5X Cable on 6P → "charging rapidly"

Conclusion from above → 6P Charger suspect

  1. Later, 6P Charger + 5X/6P cable on 6P → "charging".
  2. By this statement , I guess you mean 5X/6P Charger and 5x cable on 5X → "rapidly charging"

So now my Huawei phone can't charge at full speed with the Huawei charger, but my wife's LG Nexus 5X can without issue

Conclusion from above → 6P Cable suspect

You could purchase a 6P Cable from here, being Google recommended and it should be fine IMO and verify current using Amplify app. If that doesn't fully fix the issue, then you may need to purchase 6P charger also as indicated from 6 to 8

I don't think it is OS issue since switching to stock didn't help (your question doesn't make it clear if custom OS was flashed only on 6P or both)- only way to rule this out entirely is by switching to stock on both

Let us know the result

EDIT: Based on the clarification by OP , I strongly believe that replacing 6P charger should fix the issue (since cable issue is ruled out) and nothing points to device problem All the best

  • Points 5-9 are what I meant to convey, but I left some details out at the end: 5X charger + 5X/6P cable on 6P→"charging rapidly" and 5X/6P charger + 5X/6P cable →"charging rapidly." It is only the 6P charger on the 6P that is causing a "charging" message. I've updated my question to communicate this. Commented Mar 23, 2016 at 6:34
  • 1
    Thank you, I will purchase the same OEM charger and see if the same behavior occurs, and when I do, I'll relay the results. The reason I was skeptical was because one phone worked using the 6P charger and the other didn't, so I thought there may be more to it. I know the charger is the most likely issue, but I was curious as to others' thoughts. I'll report back when I've tested it. Commented Mar 23, 2016 at 6:41
  • Success. The replacement works fine. Commented Mar 29, 2016 at 1:40
  • Great to hear that. Thanks for updating. All the best
    – beeshyams
    Commented Mar 29, 2016 at 2:29
  • I have the opposite situation: my 5X charges slowly with "Charging" message while my friends 6P "Charging rapidly" from my LG charger. Commented Jul 11, 2016 at 15:50

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .