I have an HTC Desire with T-Mobile Germany branding. Last Sunday I finally got the long-awaited Android 2.2 update from my operator. The update ran successfully. However, since then it doesn't get the GPS location! The blue dot won't lock on Google Maps. Another GPS-App, "Gps Status" cannot get the coordinates, even after almost half an hour. Restart or reinserting the SD-Card doesn't help. I wonder if anyone here experienced something similar after the update.


  • Greetings from Spain - had exactly the same problem after the 2.2 update. Contacted HTC tech support who got me to jump through hoops: soft reset, hard reset, reinstall 2.2, etc etc etc but no joy. I said that that one of the main reasons I chose Android and HTC was the GPS orientated apps and that if the handset didn't work after the update then I would like a refund or a swap to a handset that did actually function as advertised. They told me that the problem was with my cell phone provider (Vodafone) not them and to take up any further problems with Vodafone. Was disappointed with HTC becau
    – Raf Fernandez
    Commented Dec 16, 2010 at 9:52
  • 1
    Hi, did anyone came out with a solution? I have the exact same problem (GPS doesn't work anymore since the Android update) and none of what is proposed above works. Thanks, arnorev
    – arnorev
    Commented Jan 7, 2011 at 14:49
  • I seem to have the same problem. When I finally do connect the position is a couple of hundred meters wrong. Really threw me off track once I was using it for directions.
    – Nailer
    Commented Jan 7, 2011 at 14:49
  • I am having the same problem. But the only thing that is different is that my phone (Desire HD) came with Froyo. So I don't know how to find a solution for this. Neither could i found the above replies helpful.. Any more suggestions..?
    – Droid
    Commented Jan 7, 2011 at 14:50

5 Answers 5


I had problems with GPS with my new HTC Desire (Froyo out of the box). I downloaded the "GPS Status" and "GPS Test" apps which showed only two satellites but were not locking them. Even Google Maps didn't get a GPS lock. I went outside of my room and tried but no luck. I switched off the cell, removed the battery, SD card and SIM and then put them back and restarted but still no luck.

Then I installed GPS Essentials from the Android Market. I launched the application and changed the following settings:

  • Gps update interval -> 10 seconds
  • Tracking update interval -> 10 seconds

After this I tapped on "satellites" on the main screen while standing outside. It detected 8 satellites in a few seconds and it was able to lock to 7 of them. After that everything started working including "GPS Status", "GPS Test" and Google Maps (even inside my room).

  • 1
    How does this affect your battery life? Commented Nov 6, 2013 at 17:43

I had this gps fail happen and when I first used GPS status app it rebooted the phone.

I had travelled to Adelaide from Perth and back and then used the app Skydroid(golf) for the first time since froyo 'upgrade' to discover it wasn't working. Using google earth in Perth had my location still in Adelaide.

Whilst in Adeliade I has some trouble getting it to correctly set the locataion time which was set to automatic use network provided value.

I unchecked this and set the location time to Perth and restarted the phone and everything worked with full gps accuracy.

My theory is that the froyo 'upgrade' some how srews the timebase registry setting that the gps uses to locate and sync with the sats. Some how either by forcing the time reset or the reset caused by GPS status app this was reset and al works well.

Very shonky testing from HTC/google i think.


try using gps status , go to option , capteur,manage a-gps state , choose first reset , then redo and choose download . and do it outside for the first time , it's important. also , check your APN settings in Wireless and network > Mobile network > APN name . Check that the apn selected have "supl" in APN type (in the bottom of the list) , for example "default,supl".

  • That doesn't help. The strange thing is that, sometimes it locks in 5 seconds, sometimes not even after 1 hour! That makes it hard to regenerate the error and find the cause...
    – ercan
    Commented Sep 30, 2010 at 15:57
  • can you show the file /etc/gps.conf ? (normally with a file manager you can)
    – eephyne
    Commented Oct 1, 2010 at 8:46
  • Yes, it looks like this: NTP_SERVER=north-america.pool.ntp.org XTRA_SERVER_1=xtra1.gpsonextra.net/xtra.bin XTRA_SERVER_2=xtra2.gpsonextra.net/xtra.bin XTRA_SERVER_3=xtra3.gpsonextra.net/xtra.bin SUPL_HOST=supl.google.com SUPL_PORT=7276
    – ercan
    Commented Dec 17, 2010 at 16:11

Which version are you updating from? Since Android 2.1 (or 1.5?), most applications will not be able to turn on GPS automatically, for privacy reasons. You need to enable GPS setting: Settings > Location & Security > Use GPS satellites; there are widgets that allows you to enable GPS from the home screen as well.


I have a HTC Desire that is using 2.2 (though when I got the phone, it was already running 2.2)

I've found the GPS to be pretty good in general - there are times when it is a bit patchy (loses GPS signal even though the surroundings are the "same") and slow to pin-point my location.

What I've found helps is to turn on 3G data while using GPS - this seems to greatly assist the accuracy and speed when finding your location.

Also, a reboot of the phone (or if you feel lazy/in a hurry - turn airplane mode on/off) might help kick some sense into the phone.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .