I've been having trouble with my phone lately so I decided to back up my data and factory reset, but every time I want to do it the "reset phone" button does not work, I can't even press it. I have also tried to hard reset but when I get to the screen where I choose factory reset (the screen where there is a android guy saying "no commands"), there are no commands to choose so that is also a negative for resetting.

  • Sounds like you'll have to resort to fastboot and stock firmware. Commented Mar 24, 2016 at 10:23
  • how do i do that Commented Mar 24, 2016 at 10:30
  • A quick Google search: XDA Moto G Flashing Guide Commented Mar 24, 2016 at 10:39
  • Maybe you check our factory-reset tag-wiki, which also mentions an alternative way to do a factory reset, not requiring fastboot. Also see: How to do Factory Reset
    – Izzy
    Commented Mar 24, 2016 at 12:42
  • Oh, wait: "The Android guy saying "no commands"? That sounds as if you've already been to your devices custom recovery and have wiped /system and/or /recovery, so it no longer has any OS installed. In this case you've really messed up, and flashing a new firmware via fastboot is the only way out.
    – Izzy
    Commented Mar 24, 2016 at 12:46

3 Answers 3


don't worry. Do just what I say:

  1. Turn off you Motorola Moto G 2nd Gen(I mean moto G2).
  2. Afterwards press and hold the Volume Up and Volume Down for about 2-3 seconds.
  3. While still holding these keys press the Power button for a short while and release all buttons.

    enter image description here

  4. Then select option Recovery by using to navigate Volume Down, and to confirm Volume Up.

  5. In the next step hold down the Volume Up for a few seconds when an Android logo appears on the screen.
  6. While holding the Power button, press and release the Volume Up key.
  7. Press Volume Down to choose "wipe data/factory reset", and then push the Power button to confirm.
  8. Select "Yes--delete all user data". Use Volume Down button to scroll and Power button to select.
  9. To restart the phone, select "reboot system now".

    Success! The hard reset is done!

Source : All credits go to hardreset.info

  • This will not help the OP, his OS is corrupted according to the conversation above. Consider providing fastboot flashing instructions rather than reset instructions which he has already tried. Commented Mar 25, 2016 at 6:16
  • 1
    Just had the same problem with a Moto G2: I wasn't able to click the button to reset. So I tried your instruction and it worked perfectly. Thanks.
    – Paolo
    Commented Oct 6, 2016 at 9:20
  • @Aaron Gillion - how do we give flashing instructions ? I face the same issue with android one and also if it swtches on its stuck on the welcome screen.
    – DSS
    Commented Dec 25, 2016 at 1:34

but when i get to the screen where i choose factory reset (the screen where there is a android guy saying ''no commands''), there are no commands to choose so that is also a negative for reseting, thanks in advance...

This 'no commands' screen is actually part of the process. When you get this screen, continue with step 6. as explained earlier.

  1. While holding down the Power key, press and release the Volume Up key, then release Power'

I also got the 'no commands' screen but after checking this motorola support page I found roughly the same steps as described earlier and it worked!

Good luck!!


Try installing TWRP, or just unlocking the device. when you unlock the device the device will factory reset and if you want you could install TWRP. to unlock your device, open "Developer Options/Settings" in the settings app and click "Allow OEM Unlock[ing]". Then enter fastboot and on your computer write:

fastboot oem unlock [Unlock Key From Motorola's Website]

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .