0

so i have an at&t s6.

suddenly stopped fast charging. and when i say "stopped fast charging," i mean charges slower than molasses now. takes literally about 4hrs to charge from 80% to 100%.

tried multiple known good chargers and cables and verified with both another s5 and s6 activ. found that the computer won't recognize it anymore magically.

i am rooted and have uninstalled a bunch of bloat. shouldn't matter right?

also in developer options- i can check usb debugging, but then in the secret menu (*0#*0) or whatever, mtp+adb is unchecked. if i check that, then go back to developer options, usb debugging is unchecked.

I even pulled apart the phone and put in a new daughterboard in case the thing port is broken and put in a new battery both to no avail.

  • First rule of thumb in a situation where charging doesn't work properly, and connection to PC doesn't work properly. Check your cable. The cable might be faulty – KhoPhi Mar 27 '16 at 19:51
  • 1. S6 uses fast charging which is by design disabled if you charge with phone with screen on. Is the behaviour same with phone switched off? 2. Measure the current using an app like Ampere on Play Store, say 15 minutes after you plugged in from a low battery level and then when it seems to charge extremely slowly. Do this with supplied charger and other chargers as well and revert please – beeshyams Mar 28 '16 at 2:46
  • Reading the question again prompts this-1. are you sure 4 hours to charge last 20% is consistent? 2. Other adaptors you have tried, how long did it take for last 20%? 3. Changing cables didn't help? – beeshyams Mar 28 '16 at 9:15
  • It's about 2.5hrs if I don't touch it from 80 to 100. Charges the same screen on, off, and phkne off. Put in a new OEM battery and bought a new charger and cable from Samsung. Verified the charger and cable were good on another phone. Thought it might be the USB port. Put in a new one of those also. No change. With Ampere I'm getting 180-300mA regardless of what charger I use. – justin Apr 3 '16 at 18:12
  • most probably this is an issue with your hardware, not software. What you want to do now is 1. check your phone USB port. With rough usage and hard unplugging it tends to get damaged easily (hence the switch to better type-C ports in new phones). Check if a specific angle gives you 'fast charging' message. If so, service center can change it for you. \n 2. check your charging / USB cable. If it is faulty or is shorting then that can definitely be the cause. \n 3. Try connecting to an alternate power source. Maybe your PC ports are undervolting. – axolotl Apr 4 '16 at 7:07
1

Had the same problem.. sm-920v Solved: Just cleaned the usb-charging port.. pc detect and fast charge working again.. Note: cache partition erase didn't work

| improve this answer | |
  • 1
    How did you clean it? – Matthew Read Aug 13 '17 at 18:25
0

Ok so to update- now on my 3rd USB port/ daughter board with no success. Still charges about 20%/hr when not being touched while plugged in, no computer connection, and charges halfway normally when on the wireless pad. Did some more internet scouring and found this guy doing a power amplifier swap:

https://www.youtube.com/watch?v=x__8r-UiCSo&feature=youtube_gdata_player

Gonna give it a shot. Got one for $11 on eBay. Props to the Chinese for having really cheap stuff. Thing should be here in two weeks.

| improve this answer | |
  • This should be added as an edit to your question instead of an answer unless you know that it works. – karel Apr 15 '16 at 12:42
  • Did the power amplifier swap fix the problem? Mine does the same, charging ridiculously slow and won't connect to the computer. – Crid Apr 8 '18 at 5:09

Not the answer you're looking for? Browse other questions tagged or ask your own question.