0

I have got 2 keyboards in my phone: Google Keyboard and AnySoftKeyboard. Google Keyboard is my primary keyboard. I want to enable AnySoftKeyboard as my primary keyboard via ADB (I use ADB because the 'Language and Input' subsetting crashes my Settings app for some reason). But the problem is that, although I enable it and it works while my phone is on, after a reboot it doesn't work and my primary keyboard becomes Google Keyboard again. If I try to disable Google Keyboard so that AnySoftKeyboard has a hope of working, my System UI and Launcher crash at startup, making my phone go nuts (I can only unlock my phone and reboot it or shut it down).

HOWEVER, because of past experience with this, even if Google Keyboard were uninstalled, a user keyboard app (unlike a system keyboard app) does NOT launch at startup (even when enabled via ADB), even if I go to an app like Messenger and try to type something (note: my system doesn't behave weirdly if I uninstall Google Keyboard).

So, my question is, how do I make sure that, after a reboot, AnySoftKeyboard will BOTH be a functioning and primary keyboard app? And why does my system UI and Launcher crash when I try to do a modification to Google Keyboard other than uninstalling it?

Phone: Acer V370 Android version: 4.2.2

  • This may be worth trying: android.stackexchange.com/questions/136456/… – Android Dev Mar 28 '16 at 18:43
  • @Android Dev Tried this, doesn't work. It executes the commands perfectly, the keyboard I want to enable works, but after a reboot everything goes back to what was before I did any of this. – SLester Mar 28 '16 at 18:47
  • @AndroidDev ^ ^ ^ – SLester Mar 28 '16 at 18:55
  • I'll keep researching, but atm I can't find an answer for you. – Android Dev Mar 28 '16 at 19:25
  • 2
    @Firelord So far I used: adb shell settings put secure default_input_method "mID of AnySoftKeyboard" adb shell ime enable "mID of AnySoftKeyboard" (just in case the first one doesn't work for some reason) Then: adb shell ime disable "mID of Google Keyboard" This is when my phone had the problem with System UI and Launcher, in which case I re-enabled Google Keyboard (because it was a system app) with commands shown here: [android.stackexchange.com/a/56621] Also, used adb uninstall "AnySoftKeyboardPackageName" to uninstall AnySoftKeyboard in case it was creating a problem. – SLester Mar 29 '16 at 17:36
1

I managed to solve this. To make AnySoftKeyboard my main keyboard, I had to:

  1. Turn it into to a system app (with Link2SD)
  2. Reboot as instructed
  3. Put the following commands via ADB:

adb shell settings put secure default_input_method com.menny.android.anysoftkeyboard/.SoftKeyboard

adb shell ime enable com.menny.android.anysoftkeyboard/.SoftKeyboard

(I put both just to be sure, but I think putting only the first command will work fine)

  1. Uninstall Google Keyboard (with Titanium Backup)
  2. Reboot just in case anything had yet to be sorted out

And done.

The most important part was making it a system app, because as a user app it would either:

a) not be the primary keyboard after a reboot

b) flat-out refuse to function (even if it was the only keyboard on the device).

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.