I have been trying to update the system apps on my android phone, where in I get an error mentioning that the application which I'm downloading can't be installed. (Error code :- 104)

When I searched this problem on the internet, most solutions say "You have to root your cell phone and then try to update/install the respective application on your phone."

As I don't want to root my phone, is there any better solution to solve this problem instead of rooting my phone ?

And when I tried to install updated .apk file externally it shows error enter image description here


Click on settings > backup and reset > factory reset then say yes to clean your phone.

If you try to factory reset your phone, this will do your phone automatically update your phone with initial version of your applications.

Then try to update your respective built-in application from play store, it will solve your solution.

  • 2
    The OP wants to update stock apps via Play Store. – Aaron Gillion Apr 3 '16 at 8:18
  • 1
    If you factory-reset your device, that doesn't "automatically update your phone with initial version of your applications" but simply remove all updates, configurations, etc. – see our factory-reset tag-wiki for details. As a side-effect it will also clear the cache of Google Play Store, which might solve this issue (or not); but that's like killing a fly with atomics if you don't even know where the fly sits. – Izzy Apr 3 '16 at 10:07
  • Removing all updates, configurations, etc also means the same which is nothing but it brings back to initial version. – Surendar Apr 3 '16 at 10:45

Open App Info of Google Play, clear cache and/or data and try updating the app again, should help in resolving that error.

If it doesn't help, and you require the update urgently, try downloading an APK file of that particular app, enable "Unknown sources" in Settings > Security, and open the downloaded APK using PackageInstaller. A good source to find the APK file of the app is APKMirror.

  • I updated the question and added an image of showing error when I tried to install updated .apk file – Vijay Gupta Apr 3 '16 at 12:30
  • @VijayGupta basically that means you already have the updated app. – rjt.rockx Apr 3 '16 at 12:42
  • No I checked application version that was an older verson, whose update is showing in play store – Vijay Gupta Apr 3 '16 at 17:52

Actually you need to take a build of apk and sign with google with the system/laptop from which you take a base apk uploaded in google play store.

Because conflict in signature(SHA) key of system will lead to this error while updating the application.

you can get system SHA key using below terminal command

keytool -list -v -keystore ~/.android/debug.keystore -alias androiddebugkey -storepass android -keypass android

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.