9

My Android phone loses the Wi-Fi connection when I'm at home in the very short time after it is connected, usually around the first 30 seconds. Sometimes it works fine, but not often. When it isn't working, the Wi-Fi icon remains present. But I can't for instance browse to the IP of router 192.168.0.1.

The same phone is working properly with my work Wi-Fi. Other devices don't have problem with the home WiFi.

I'm a little lost and don't know how I can find the reason an fix it.

5
  • 3
    I don't think the Android phone is the issue, it's his router. So the question is actually on topic.
    – Sickest
    Mar 28 '16 at 19:50
  • 1
    How far are you from the router when it loses connection? Some android phones have weak wifi receivers and that could be causing the loss. See if it also loses the connection right next to the router. If it doesn't then the problem is that your router transmits a weak signal, and your phone has a weak receiver, and the two together result in what you are seeing. If it still keeps losing the connection next to the router, but has no problem with all other wifi, then time to replace your router.
    – Florian
    Mar 29 '16 at 8:14
  • No it doesn't depend on the distance. And it shows always good signal. And it remains to show it also after it breaks the connection,
    – Alexander P
    Mar 30 '16 at 14:45
  • Try removing any booster apps.
    – user193547
    Oct 24 '16 at 14:52
  • 1
    I have this same issue with different devices on different routers, even when just a few feet away from it, really not sure why that is. It's been happening a lot on M
    – DWils
    Feb 23 '17 at 22:47
5

I can't say that I completely understand how but the issue was solverd after I changed the DNS settings of my phone (for my home WiFi). I set it to Google default DNS 8.8.8.8 and 8.8.4.4.
And since that never this problem again.

Why the phone was loosing the whole connection is still unclear to me (though it remains now pure theoretical question)

2

Depending on the version of android you are running you can try going to System settings> WiFi> Advanced> Tap "Keep Wi-Fi on during sleep" and select "Always"

3
  • Try rebooting your router
    – TheStarvingGeek
    Mar 28 '16 at 20:13
  • I have this issue already several weeks. And rebooting router was the first I did (many times). It helps. But just same as turn off and on the Wifi of the device. Just for a while.
    – Alexander P
    Mar 28 '16 at 20:25
  • He said that it works fine with his work Wi-Fi. If this were the problem then it wouldn't work on any Wi-Fi.
    – VirtualDXS
    Mar 28 '16 at 20:54
1

It sounds like you have a bad router, or possibly too many devices connected. Many routers can't handle that many devices connected at once via Wi-Fi.

1

I solved changing the modem setting. The last versions of Android has problems with the WiFi channel 1 and 13, so the better way is to setting the transmission channel NO automatic, but fixed to an intermediate channel like 5, 7, etc... Since I've done this change the connection works great.

2
  • 3
    This answer does not convey any useful information about why one channel should be used over another.
    – mattm
    Jan 2 '17 at 22:50
  • I don't even know what it's trying to say.
    – isaaclw
    Aug 11 '18 at 19:46

Not the answer you're looking for? Browse other questions tagged or ask your own question.