1

I'm trying to access a remote server using SSH on my phone but it dosent seem to work no matter the method/app I try.

I've tried various SSH apps in the play store and recently tried Termux's CLI (which seems great may I add), it successfully got the openssh packages for it, but I still can't seem to access my server from my device using the generic ssh username@domain/ip:port.

I can confirm SSH works fine from desktop using Putty on the same LAN as my phone. I can ping the server from my phone too using both the server's IP and domain.

Termux throws an error when I attempt to connect, something to the effect of Cannot resolve hostname even when using the IP address? Though, like I already said, pinging it works fine. The port is definitely open on the server as well since well, I can connect from my desktop perfectly fine.

I'm running Android 6.0.1 (latest build), my device is rooted and Busybox is also fully installed.

Any help getting my phone connected would be much appreciated!

migrated from superuser.com Apr 5 '16 at 12:28

This question came from our site for computer enthusiasts and power users.

3

OpenSSH doesn't use user@host:port notation. If you need to specify a port, you do it with -p port.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy