1

I'm using a Samsung Galaxy S2 mobile.
Since last week I have not been receiving any kind of incoming messages on my mobile.

  1. I tried message centre no. deleted and re-enter, and powering off my mobile and restarting also.
  2. My network setting also perfectly cross-checked, but still the problem was not resolved.
  3. I called many times to customer care, but they are not properly responding at all.
  • 1
    Are you referring to SMS and MMS? Do calls and mobile data work? – Matthew Read Apr 6 '16 at 14:45
1

If its not a network related issue then the problem could be from device itself. As Samsung Galaxy S2 has a built-in spam functionality in messaging.

So inorder to verify the same, just try sending sms with any another device on your S2 and just see if the other device gets a delivery confirmation report or not, if it does, and you still don't receive that sms. Then in this case you've unknowingly/accidentally switched on the spam function your Galaxy S2.

Follow the instruction below to unblock your incoming SMS

Using the Settings menu

  • From any Home screen, tap Messaging.
  • Tap the Menu key.
  • Tap Settings.
  • If necessary, tap Spam settings to select the check box
  • Tap Unregister number as spam (if any)
  • Touch and hold on the desired number and then tap Delete
  • Tap OK

Hope this would resolve your problem :)

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.