1

Very recently the Wi-Fi Connection on my Verizon Galaxy S4 has decided to turn itself off at will. This issue is device specific as I have other devices that are not experiencing this problem. The device is Rooted. I have tried: setting a static Ip, resetting router, switching airplane mode on off, changing channels. None have worked. Next is a factory reset, which I do not want to do. So in summary, does anybody have any more tricks I can try to solve this?

1

Possibly there could be couple of reasons for this sought of behavior from your device..

  • Check if it happens only when any battery power saver app is switch on, as most of the inbuilt/third party battery saver apps have access to your device's WiFi functionality and they switch it off whenever there's a event triggering the app's pre-assigned/pre-programmed parameter telling the app about high usage of battery by device Wi-Fi transmission/reception.
  • Another Scenario which might make this happen is the low WiFi signal. Mostly all higher versions of Android OS have this inbuilt functionality to turn off the WiFi whenever available signals falls to a certain level. Some device manufacturers provide advanced setting under WiFi setting to enable this control of OS, while some keep this function as preassigned in OS disabling user. Look for WiFi Sleep Policy in your device settings and update the settings as per your requirement. You can also refer this tutorial to learn more about adjusting the Samsung Galaxy S-4 WiFi sleep policy settings.

Hope adjusting your device WiFi policy will will resolve your problem, incase if ever after the adjustment of WiFi settings, you still face any issues do revert back with exact situation, I'll try to look deeper into your case.

|improve this answer|||||

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.