1

I have a 5th gen Kindle Fire running 5.0.0 version of FireOS. I'm trying to use the April 6 Version of RootJunkySDL supertool to root the device, remove lock screen ads, and install Google Play store. The problem that I run into is with the Google Play Store. Once I input account information, I get the RH-01 error on the store main page. Additionally, I get the "An application requires an update requested by google play services" notification.

I've tried many of the online resources for fixing the error, forgive me for not being able to locate the most comprehensive resource I've found so far. The resource I used included 8-10 different methods ranging from clearing the cache of the Play Store and Google Services Framework apps to logging in via browser to your account and trying to install a random app.

My procedure is as follows (from a factory reset device running FireOS v5.0.0):

  • Select Language
  • Set up WiFi
  • Device downloads software update to 5.0.1
  • Log in Amazon account
  • Supertool Option 6: Root your device. Reboot.
  • Supertool Option 2: Install Google Play Store
  • Input google account
  • Error retrieving information from server. [RH-01] AND "An application requires an update for google play services" notification.

I've been through this several times in various sequences. Has anybody gotten it to work. What problem am I running into? I've chased down troubleshooting for hours.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.