0

I have this Chinese Phone which is a Yun OS, I've tried all different types (Architecture, Android Version, Screen DPI) of Google Play Services from APKmirror site but all goes "Unfortunately, Google Play Services has stopped".

My phone is also not rooted. Tried many root apps (kingroot, kingo, etc.) mobile/pc but no luck.

0

TL;DR answer: It won't work.

Google Play Services relies on several apps and libraries to reside in a few different system directories, you can't just "install" Google Play Services, you need to flash them into your system with a 3rd party recovery like TWRP or CWM Recovery. The gapps are available from OpenGapps and other sources.

Although a little research tells me that Yun OS is NOT Android, although it is based on AOSP.

According to Google, Aliyun (YuOS) is a forked but incompatible version of its open-source Android operating system.

Yun OS incorporates its own virtual machine, which is different from Android's Dalvik virtual machine.

And some searching also show very few, if any, people who have gotten the Google Play services to work, probably the biggest reason is YunOS uses a unique VM that is not Dalvik or ART, therefore it will not work.

| improve this answer | |
  • This is all the answer OP needs I assume. The reason is explained as clear as an for-the-end-user-to-understand answer gets. – SarpSTA Jun 23 '16 at 0:40

Not the answer you're looking for? Browse other questions tagged or ask your own question.