According to these instructions there should be a "Convert to file encryption" option in Developer settings, but it's not there on my Nexus 6 running stock N Preview 1. When I try to search for it in the Settings app, it does show up:

enter image description here
click for larger image

Unfortunately, tapping on it simply brings me right back to Developer settings where that option is not found.

The alternative instruction is to reboot to bootloader and issue the fastboot --wipe-and-use-fbe command, but it fails with "fastboot: unknown option -- wipe-and-use-fbe" error. I am running the SDK Tools version 25.1.1 rc1, and Platform-tools version 24 rc1 from the preview channel of Android SDK, with latest fastboot utility (version 102d0d1e73de-android).

I performed a complete wipe (system and userdata), and flashed all the NPC56P images manually (bootloader, radio, recovery, system, cache, userdata.) The phone is encrypted, Screen lock is set to "PIN", and Secure start-up (requiring PIN before boot) is enabled.

Is this feature simply not available in Preview 1 and/or Nexus 6? How can I enable it?

  • Are you sure the fastboot you're calling is the one from the new SDK you installed? I've been caught out before by having two fastboot binaries of which the older was the first on the path.
    – Dan Hulme
    Commented Apr 12, 2016 at 9:59
  • @DanHulme I am fairly certain that I am running the latest preview version of fastboot. The current stable one (rev 23.1) doesn't even have a "--version" switch, whereas the preview one (rev 24 rc1) does, and reports it as "102d0d1e73de-android". I have only one fastboot.exe installed on this machine, and just in case I navigate to the installation directory in Command Prompt before issuing the commands.
    – Chahk
    Commented Apr 12, 2016 at 12:38
  • No idea of Android N. So a very humble opinion. disable system level encryption first and then go for fbe. might work.
    – Iftekhar
    Commented Apr 14, 2016 at 5:31
  • @IftekharAS System-level encryption cannot be disabled on stock Android 6.0 and above. On Marshmallow and N the phone gets encrypted by default, and the only way to remove encryption is to use a custom kernel.
    – Chahk
    Commented Apr 15, 2016 at 13:56

2 Answers 2


I'm afraid that in Preview 1 this is only available on the Nexus 5X and the Nexus 6P. In Preview 2, support for the Pixel C is added. No other devices are supported at the moment. Sorry!

  • That's a bummer. Any source for this information?
    – Chahk
    Commented Apr 16, 2016 at 21:55
  • I'm not sure where it's been publicly stated. But the option only appears in the developer menu if it's supported on the device. Commented Apr 16, 2016 at 23:01
  • 1
    To be clear: source is me, just now; I'm very closely involved in working on this feature, and I just checked our source tree. Commented Apr 16, 2016 at 23:11
  • Thanks for the information, @PaulCrowley. Is the feature going to be rolled out to all devices (that get updated to N) eventually?
    – Chahk
    Commented Apr 17, 2016 at 1:15

Definitely you are using old version of fastboot.Please use newer version of fastboot of Android N.It worked for me.

You can check various option available with your fastboot. fastboot --help.

--wipe-and-use-fbe On devices which support it, erase userdata and cache, and enable file-based encryption

But it does not enable file encryption for me after executing the above command.

  • I tried this. Was successfully able to --wipe-and-use-fbe but my internal storage was left unencrypted. I encrypted it again from settings > security, and it encrypted. However, this is the usual entire partition encryption and not the file based encryption. Did you get it to work?
    – blueren
    Commented Aug 27, 2016 at 15:34

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .