0

I installed a rooted Android 6 ROM on my Lenovo K3 Note. Then I unrooted the phone. Now I want to reroot it, however it doesn't work. I have tried flashing all sorts of version of SuperSU in TWRP and they all claim to install fine but every time I reboot the phone and test if it is rooted it fails. The SuperSU app says "there is no SU binary installed". I have tried wiping the cache/dalvik. Like I said, I tried various versions. I don't know what else I can possibly do.

  • Have you tried different methods of rooting your device, like Framaroot, Kingo Root, etc. ? – rjt.rockx Apr 9 '16 at 7:29
  • I did try Kingo Root. Wasn't compatible. – Moss Apr 14 '16 at 21:27
0

I used to have the k3 right before I bought my 5x. So here's what I would try if I were you. First, when you're in twrp, are there red bars on the top? Like in the menu is most stuff red instead of blue? If this is the case then you need to relock and unlock your bootloader. Twrp is unusable and it means something along the lines that your bootloader is messed up. Reflashing twrp or another recovery won't fix it. If you dont have red in twrp, then I would try this forum. It's a guide on how to root manually, and it will definitely work on whatever rom you are using and you won't need to flash a new one.
Good luck.

-The 14 year old androider

  • There was no red in TWRP. The link you sent me to is basically exactly what I have already attempted except using CWM instead of TWRP. Maybe that would work but who knows. I gave up attempting to reroot the existing ROM and ended up flashing a new rooted ROM. So I guess this will remain unresolved. – Moss Apr 14 '16 at 21:32

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.