1

On a stock Verizon Galaxy S6 running 6.01, I'm able to connect two different USB Ethernet devices by way of a USB OTG adapter cable. One is a generic USB hub/Ethernet combo. The other is an Apple USB Ethernet adapter.

Both of these devices seem to work with the drivers already built-in. I found an app on the Play Store that does nothing but dump the output of ifconfig. After plugging in the devices, I see them show up in eth0. (In fact, I can even plug the Apple adapter into the hub side of the other adapter and get eth0 and eth1 simultaneously... the phone powers them both.) I also get link lights on my generic adapter. (The Apple adapter doesn't have link lights.)

It's clear that the interface is brought up, but it seems DHCP client isn't running for these adapters. After reading around, many folks suggest tips for assigning an IP and setting up routing manually. There are also several apps for doing this, but all require root.

I know it's a long shot, but is there any way at all to enable the DHCP client on eth0 without root, on this particular device? The hard part of getting drivers in place seems to be already done. The adapters are working, I just need the network stack up and running.

  • 1
    The usual dhcpcd and dhclient programs need to be run as root, unfortunately. How about restarting the phone with the adapter plugged in? (Perhaps the OS only runs a DHCP client on interfaces detected on boot) – Piskvor Jan 25 '17 at 14:38
  • @Piskvor Excellent idea, I haven't tried that yet. I'll give this a try once I find my adapters again. Thanks! – Brad Jan 25 '17 at 17:10
  • Tried on S5, doesn't work there :( – Piskvor Jan 26 '17 at 11:53

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.