-1

My phone says failed to validate boot image. I need to flash it with stock or custom rom but my usb debugging is off. How to toggle it on from outside coz my phone is dead now , it goes nowhere from fastboot screen.

When I switch on my phone [moto e], it is going into fastboot mode instead of normal powerup. And it says

hab check failed for boot

failed to validate boot image

Fastboot Reason: Fall-through from normal boot mode

Except that my touch and display is fine.

what to do now??

-thanks for replying

4
  • 1
    Please mention your device details.
    – rjt.rockx
    Apr 9, 2016 at 18:53
  • You don't need USB Debugging to flash anything -- that controls ADB access while the phone is running. What issue are you encountering with flashing from recovery or fastboot/download mode? Apr 9, 2016 at 20:29
  • @MatthewRead My phone is not listed when I type 'fastboot devices' in fastboot cmd prompt after connecting to pc, so cannot go further to flash recovery img.....usb drivers are updated, doesn't it need usb debugging to be enabled??
    – Pawan
    Apr 10, 2016 at 10:56
  • That sounds like a connection or driver issue. Assuming you're using Windows, run Device Manager and ensure that your phone is listed there without the yellow error symbol and that there are no unknown devices. (For OS X see here and for Linux run lsusb). You may need to try a different USB cable or port. Try also manually booting into Fastboot with the key combo (see the first 4 steps under the Step 4 section here). Apr 10, 2016 at 19:34

1 Answer 1

0

Go to http://forum.xda-developers.com/showthread.php?t=2759495

It shows you step by step how to recover from brick, also on this site you will find all you need to fix your phone 😊

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .