I am not sure this is the right place to ask this question.? I have enabled pattern lock in my android device. Just for curiosity I am trying to disable and keep only swipe to unlock option but I can't do that. Is there a way I can disable these patter/pin lock in device?


  • is the options disabled in your phone? what is your phone model and version of the android you use? Commented Apr 11, 2016 at 7:10
  • Do you have an Exchange email account on your phone? Some companies enforce certain security measures, including that you must have a pin.
    – Chro
    Commented Apr 11, 2016 at 12:00
  • @Chro no but I have installed android administrator app. I guess it stopped to me to do that. Commented Apr 11, 2016 at 13:06

2 Answers 2


This is the right place, but it seams easier for people to help if they know your device as pretty much every settings screen is different for every device manufacturer.

For instance in my G4 I can:

  1. Go to Settings
  2. Go to Display
  3. Go to Lock screen
  4. Select from (None, Swipe, Pattern, Pin, Password)

As it seams None is disabled for you, I'm guessing you had an app installed that required an Administrative rights. Go to settings -> General -> Security -> Phone administrators -> Remove the app that made you set the screen lock from the administrators list (Or if it was a certificate from an app, go to Certificate Management and clear credentials)

  • but none is disabled in my Moto G2 Commented Apr 11, 2016 at 7:08
  • Go back to swipe first. Commented Apr 11, 2016 at 7:10
  • Okay let me check. Commented Apr 11, 2016 at 7:11
  • If this doesn't help check my answer, added more to it. Commented Apr 11, 2016 at 7:16

I have rooted device. Device is connected to computer with USB cable. And those commands helped me out:

adb devices
adb shell 
cd /data/system
rm *.key

Credit to: https://appuals.com/delete-android-security-pin/

  • This helped me wipe my screen lock on my damaged Honda Clarity headunit after an accident, the digitizer was damaged but thankfully i had turned USB debugging on once before. Thank you!
    – Arctiic
    Commented Jun 15, 2023 at 1:52

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .