I have an android with an app installed. The app was installed with one account that I have no access to. I removed the account but now I can't uninstall the app. Does that make sense? What can be done?

  • 1
    how are you trying to uninstall app? Using Google play store or via Settings? Apr 11 '16 at 10:17
  • 1
    What have you tried? There are several methods to uninstall an app: via PlayStore, via Settings › Apps, via ADB
    – Izzy
    Apr 11 '16 at 10:29
  • using the play store
    – IttayD
    Apr 11 '16 at 15:34
  • And what happens when you try from the Play Store? Try via Settings too. Apr 11 '16 at 17:48

I just ran into a very similar issue, where I was trying to update an app owned by a different account. The fix was simple: I logged into the play store with the desired account on the web from my desktop, then installed the app from there. The app updated successfully and its ownership switched to the desired account


I had the problem today and I found a solution that worked for me. All I did was remove the account under which the app was installed, reinstalled the app and then re-added the account the I removed. I hope this will help you and others with the same problem. Cheerio!


I had a similar problem

When we have a problem we can remove the application with adb

# find your package
pm list packages -f | grep [package_name]
# uninstall your package
adb uninstall [package_name]

But in my case it did not work. This was due that I have a Samsung (Galaxy S10) with the application "Security Folder", And I forgot that I added this app in the security folder.

If you have an application of this type, which clone an application in a container in your Android, you must also delete it in the contents of this application because it is installed a second time via another user, used by the application to secure, to be installed a second time on your phone

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.