0

I was having Marshmallow stock ROM rooted with TWRP installed. The way I had installed TWRP recoery made the monthly security updates uninstallable.

After learning the mistake, I decided to download the MOB30D build and flashed as I said in my answer.

After installing the phone was working normally. I tried to install TWRP through ADB command line and there was no error messages. When I rebooted the phone in recovery mode I find a red triangle. After some fiddling with power and volume buttons I saw the following recovery screen and used it for rebooting only: enter image description here

I tried to flash the latest TWRP version, downloading again thinking the download might be corrupted. I then tried several old version of TWRP and same result. I tried flashing stock recovery, doing all these again with erasing the recovery partition first - all results in red triangle.

I then tried Nexus RootKit flashing stock and TWRP image (downloading again); still no use. I tried Nexus Rootkit's "Boot into temp recovery image" which did not work well but suddenly worked. I flashed latest TWRP image through the temp TWRP and it too says all okay, but no joy: enter image description here

Question: I am not sure what else I can do to install TWRP. I want TWRP basically to root and for emergency purposes. What I can do further to install TWRP and if not at least root without a recovery partition.

Update I tried CWM recovery as well and same result. I tried to lock the bootloader and unlock again there by resetting everything. Still no use.

  • 1. If the device isn't rooted, how did you successfully flash TWRP using adb? 2. After flashing TWRP zip from that temp TWRP image, what did you immediately do? rebooted straight into recovery or something else? – Firelord Apr 13 '16 at 7:18
  • 1. If you are referring to "I was having Marshmallow stock ROM rooted with TWRP installed" I flashed TWRP first and installed root. 2. I rebooted straight into recovery. – Narayanan Apr 13 '16 at 7:51
1

The problem is your not flashing SuperSU or deleting /system/bin/install-recovery.sh. Android has safeguards which revert to the stock recovery thru the install-recovery.sh, SuperSU by default disables this function so I'd recommend flashing it after you install TWRP.

Steps

  1. fastboot flash recovery twrp.img or fastboot boot twrp.img
  2. flash twrp.img inside of recovery if you just booted it instead of using fastboot flash
  3. flash SuperSU-2.79-SR3.zip

OR

  1. tap the mount tab
  2. tap System
  3. go back to main screen and tap advanced then file manager
  4. navigate to /system/bin and delete install-recovery.sh

I recommend using the SuperSU route but whatever floats your boat.

0

I am still puzzled about how the recovery issue is so stubborn. However, after reading through a blog post on root-your-android-device-without-flashing-custom-recovery, I understood that you can boot your phone temporarily on a custom recovery and install root binary.

Being lazy and already downloaded the Nexus Root Kit, I just clicked Root which exactly did this and voila, the device is rooted.

I am still hunting for a solution for my recovery issue though. Thought this new approach could help some one.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.