3

I want to modify a file under /system. The problem is that is read-only, and even with root I cannot set it as read-write.

I've tried the following:


Some useful informations:

  • The device is a Redmi 3
  • Using android 5.1.1, on MIUI 6.4.7 (china developer version)
  • I have root access, and enabled it for the apps mentioned above
  • Bootloader is unlocked
  • No SD card
  • Output of mount | grep system: /dev/block/dm-0 /system ext4 ro,seclabel,relatime,discard,data=ordered 0 0

I would like to manage the /system folder directly from the phone. I'm pretty hopeless, I've tried googling 2 hours for a working solution. Thanks in advance.

4

I've found the source of the problem asking in the MIUI forums, the boot image will not accept a modified /system.

You have to use the adb interface: adb devices then adb disable-verity.

Disclaimer: I'm not responsible for any damage caused by these operations.

  • 2
    Unfortunately this only works on USERDEBUG builds. Still looking for what works for stock builds. – SAGExSDX Dec 23 '16 at 2:39

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.