1

I own an Samsung Galaxy Tab Pro 10.1 wifi (picassowifi). I flashed the recovery with TWRP and installed CyanogenMod 10 on it. After a couple of months I tried installing a nightly update for CyanogenMod but after that I couldn't boot the tablet anymore. It just crashed after displaying the bootanimation. Now I want to reinstall the old version of CM.

But there are a couple of problems that occured:

  • I can't connect to the tab via adb
  • When I tried installing CM from a zip, installation fails with "E: Unable to mount /system"
  • /system can't be mounted in the Mount-Menu of TWRP

I tried formatting the internal space, but it had no effect.

I read that "E: Unable to mount /system" could be solved by flashing a new recovery or switching to ClockworkMod. But flashing with heimdall also fails:

root@Ubuntu:~# heimdall flash --RECOVERY twrp-2.8.7.0-picassowifi.img --no-reboot

Initialising connection...
Detecting device...
Claiming interface...
Setting up interface...

Initialising protocol...
ERROR: Failed to send data!Releasing device interface...

root@Ubuntu:~# heimdall detect --verbose --usb-log-level debug

[timestamp] [threadID] facility level [function call] <message>
--------------------------------------------------------------------------------
[ 0.002649] [00000af8] libusbx: debug [libusb_get_device_list] 
[ 0.002746] [00000af8] libusbx: debug [libusb_get_device_descriptor] 
Device detected
[ 0.002799] [00000af8] libusbx: debug [libusb_exit] 
[ 0.002818] [00000af8] libusbx: debug [libusb_exit] destroying default context

root@Ubuntu:~# heimdall print-pit --verbose

Initialising connection...
Detecting device...

            length: 18
      device class: 2
               S/N: 0
           VID:PID: 04E8:685D
         bcdDevice: 021B
   iMan:iProd:iSer: 1:2:0
          nb confs: 1

interface[0].altsetting[0]: num endpoints = 1
   Class.SubClass.Protocol: 02.02.01
       endpoint[0].address: 83
           max packet size: 0010
          polling interval: 09

interface[1].altsetting[0]: num endpoints = 2
   Class.SubClass.Protocol: 0A.00.00
       endpoint[0].address: 81
           max packet size: 0200
          polling interval: 00
       endpoint[1].address: 02
           max packet size: 0200
          polling interval: 00
Claiming interface...
Setting up interface...
libusbx: error [op_set_interface] setintf failed error -1 errno 71
ERROR: Setting up interface failed!
Releasing device interface...

So my question are:

  • (How) can I fix this?
  • Is there any other way to flash the recovery in this kind of environment? Maybe manually with the Terminal from TWRP?
1

I fixed the libusbx error libusbx: error [op_set_interface] setintf failed error -1 errno 71 by following these instructions:

 echo "blacklist cdc_acm" >/etc/modprobe.d/cdc_acm-blacklist.conf
 rmmod cdc_acm # ignore ERROR is not currently loaded

After that the "Setting up interface..." step passed well for me.

  • This solution fixed the problem for me. Using model SM-T580 and Heimdall 1.4.1 on a Debian based OS. – Gob Tron Jan 14 at 23:06
0

Fix is not too much tough.

  • You need to download Odin ( It is tool like Heimdall , but has good control. It is Windows software. ) and drivers for your device.
  • Now need to open download mode. Place the tablet into Download Mode by pressing and holding Volume Down, Home and Power buttons together until a construction Android robot icon with a warning triangle appears on screen. Now press the Volume Up button to enter into Download Mode.
  • Launch Odin on the computer as an Administrator. Connect the Galaxy tablet to the computer using USB cable while it is in Download Mode. Wait for some time until Odin detects the device. When the phone is connected successfully, an Added message will appear under Odin message box. You should also see the ID: COM box in Odin will turn blue with the COM port number indicating successful connection.
  • Now click on PDA button and choose your recovery. Click start and wait to show pass.
  • Now you have TWRP as you asked.

Here is more suggestion, if this even fails to flash or something you feel going more worse. Then you will be needing stock rom to flash by using Odin in download mode. You can search for that on net. After that you can flash again your CyanogenMod rom.

NOTE: It is never recommended to flash any nightly build rom. So, please be careful before going to do like this in future. The reason behind this that nightly builds are not matured and may be some major bugs that has to be fixed.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.