0

i'm new to android. I recently bought a xperia l phone from my friend in which he had Cm11 installed i decided to upgrade to cm13 and it really messed up the phone.. the sim card was not detected and play store didn't work!!! so i came back to cm11 which then entered boot loop. So i decided to go with cm12.1. Now the pay services work like charm... BUTTTT sim not detected problem still persists!!! so can some one here gimme the link of the radio or modem files of xperia l c2104 or help me with any other solution for this problem... thanks in advance

5
  • forum.xda-developers.com/xperia-l Have you searched here? Commented Apr 15, 2016 at 7:29
  • Yes i did, but not much help from there as no one having xperia l had that problem. I installed various radio.img files and worse things happened. After i asked the question above the phone just got hard bricked!!!!! can u help :( :( Commented Apr 15, 2016 at 8:22
  • Sorry. I have not handled hard bricked devices before. Commented Apr 15, 2016 at 8:26
  • It is normal that the play store crash (you need to flash openGAPPS according to your new flashed OS). How have you flash CM12/CM13? Have you performed a full wipe (Dalvik Cache + System + Cache + Data) before the installation? Commented Apr 15, 2016 at 13:46
  • Did you check if you have the latest modem/baseband installed?
    – xdevs23
    Commented Jul 28, 2016 at 13:32

2 Answers 2

1

Your baseband was messed up. Try to flash the stock ROM and don't flash CM13.

This happened on my Samsung Galaxy A3, when its baseband was messed up when I try to install it.

-2

Yea flash stock rom of xperia...(model)..via download mode... You need PC Qpst installed on it& And to go in download mode press volume+&volume- then connect the USB cable

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .