0

Since upgrading my Moto G 2nd gen to OS 6.0 I am having issues with USB and file transfers when connected to 3 different Macs with different OSes which all worked OK before. Sorry this is a bit long...

When I plug it in, Android File Transfer (AFT) starts up automatically but I get an error window saying 'Can't access device storage'... I find the phone is in USB charging mode only. If I change it to MTP, AFT does then show the internal storage files, but will not show the contents of the SD card. I have also tried PTP mode (which would be more useful) but iPhoto does not show any of the (new) photos, which it used to before the upgrade.

Additionally sometimes the Mac appears to lock up - no keyboard or mouse control - I suspect the USB circuitry is getting locked up - even unplugging USB does not clear this. The only 'fix' is to hold down the power button to reboot.

I can see the SD card contents on the phone and can copy files on/off with OTG but this is a bit of a pain.

I've not read of anyone reporting exactly these issues.

  • Is SCP working? Also, is your device unlocked when connected to the usb port of your computer? – Luca D'Amico Apr 15 '16 at 13:56
  • SCP? sorry not sure about that? Device does not get locked when connected or disconnected from the comp (thanks) – Nigel Favors Apr 15 '16 at 14:00
  • SCP is "secure copy" (en.wikipedia.org/wiki/Secure_copy) – Luca D'Amico Apr 15 '16 at 14:05
  • I do not believe SCP is invoked as the device is able to write to the SD card - where should I check? – Nigel Favors Apr 15 '16 at 15:14
  • No, SCP is an external app. I was asking if you are able to transfer files from your device to your computer using this method. – Luca D'Amico Apr 15 '16 at 15:21
1

I showed this to a pal of mine who uses the same setup and he had the same issue. He discovered the symbolic link to the SD card was incorrect and of course not editable for non-rooted devices. He found a fix:-

  1. Eject the SD card from Setup>Storage

  2. Shut the phone down

  3. Remove the SD card

  4. Restart the phone

  5. When running, put the SD card back in.

This seems to rebuild the symbolic link and now I can see its contents again via Android file transfer - hope this might help others.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.