1

My Nexus 6p has 2 messaging services. Google Hangouts and the stock Google messenger app. I usually use the Google messenger app to send SMS, but the problem is that the message they respond with always comes through the hangouts app. Is there any way to change that so that all SMS always comes from the messenger app?

OS: Android 6.0.1 Carrier: Google Project Fi (The phone is not rooted)

Any help would be much appreciated

0

Open your settings App and search for the Apps entry in the first page.

open settings and go to <code>Apps</code>

In Apps, tap on the wrench icon at top right to open Advanced / Configure Apps.

go to the <code>advanced settings</code> using the wrench icon at top left

Select Default Apps under Advanced

go to <code>Default apps</code> under *Advanced*

Select SMS App and select the default app of your choice.

finally select <code>SMS App</code> and select Messaging

Alternatively, you can select Settings ––> Default SMS App to change it.

option in settings of SMS app

5

Devin, I am not extremely familiar with stock Android, so I apologize if some of what I try to describe does not work exactly as I try to explain it. The SMS messages on your phone is maintained in a single database. That means you can use different messaging apps for SMS and the message "streams" or "history" stays the same regardless of the SMS app you use. Within Android, you can decide which app is your default messaging app and by doing so you are saying which one will show you incoming messages. You can change this default behavior by going into your phone Settings app and then Applications. Inside that, there should be an option labelled Default Applications (I use a Galaxy, so it might be slightly different). Inside Default applications, there should be a listing for Messaging App and your default SMS app listed. I will assume that it is Hangouts. You can tap that and change it to another app - and choose Google Messages. You will still be able to use Hangouts for sending SMS messages, but incoming SMS notifications will by default show up in the Google app. Also, you may need to disable SMS notifications within the Hangouts app so you don't get multiple SMS notifications for each incoming text message. Hope this helps. Rick

  • This is exactly correct. On a Nexus with 6.0.1 it's Settings->Apps, tap the Settings menu icon, which takes you to the Configure apps screen. From there, click on Default Apps, and then it looks like this: imgur.com/a/sp1FC – Daniel Nugent Apr 16 '16 at 21:43
0

Go to Hangouts and either check or uncheck the option for using Google Fi as the SMS in the sub-options level. If you have it checked then the messages will go to FI's SMS system which is not integrated.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.