0

Hey guys i just rooted my Motorola Droid RAZR (HD) with kingroot and i want to install CM 12.1 nightly. Before i proceed, i need to unlock my bootloader. After sitting infront of PC for 3-5 hours now, i finally give up.

I downloaded Android SDK + fastboot. Enabled USB debugging and booted phone in fastboot mode. The problem is, when i try the oem commands, get_unlock_data for instance, it says "unsupported command". I am really sick of it, i need serious help.

Any alternatives to get unlock data or unlock bootloader would be appreciated.

  • Are you sure you've typed the correct commands for your device? – Android Dev Apr 16 '16 at 17:44
  • Does the Droid Razr HD unlock that way?!?! I thought you had to use an exploit to unlock the bootloader such as Motopocalypse, like described here forum.xda-developers.com/showthread.php?t=2783912 – acejavelin Apr 16 '16 at 17:51
  • AndroidDev yes i typed that command like 100 times. @acejavelin i am looking into that thread, any other alternatives would help a lot. – user3762712 Apr 16 '16 at 18:27
0

The Droid Razr HD cannot be unlocked using the standard Moto unlock procedure from there website, the only known way of unlocking the bootloader after root is achieved is via Motopocalypse written by Dan Rosenberg and available from his blog site here.

The basic jist of it is from the link above is:

Instructions

The tool may be downloaded here. It may be used as follows:

  1. Extract the entire contents of the zip file.
  2. If you are using Windows, ensure you have installed the latest Motorola USB drivers available for your phone.
  3. Ensure your device has been rooted and you have a working installation ofsu.
  4. Ensure USB Debugging mode is enabled on your device.
  5. If you are using Windows, navigate to the extracted directory and execute run.bat. If you are using Linux or OS X, navigate to the extracted directory in a terminal and execute ./run.sh.

You may also be interested in the RazrHD Toolkit 5.0 which can automate some of the processes involved, but I generally recommend doing it manually, so if something goes wrong you can see what happens and potentially correct the issue. All in one tool kits tend to mask the processes, which if they work is fine, but if there is a failure it can be very difficult to diagnose and correct.

  • i tried that, it stucks at "getvar:all FAILED (remote: unsupported command)" same as what happens at manual fastboot command line. I think i am doing something wrong. I granted ADB the root permissions, followed every step. – user3762712 Apr 16 '16 at 18:46
  • @user3762712 At this point I would go to XDA and post in the Moto Razr HD Q&A area then, or at least research there. forum.xda-developers.com/droid-razr-hd – acejavelin Apr 16 '16 at 18:48
  • Alright thanks for your time, i'll start a thread there. Meanwhile, i will look forward for a solution here as well. – user3762712 Apr 16 '16 at 18:50
  • I did this, was able to get to recovery mode using safestrap, it did not install CM 12 at first, said FAILED, then i downloaded CM 10 (stable) and it gave same error, i restarted phone and its now at login loophole, i am scared i cant even get to safe mode, i can only get to fastboot by giving 10-15 tries, please help. – user3762712 Apr 17 '16 at 2:06
  • @user3762712 Did you backup in recovery before flashing CM? If so, restore the backup... If you didn't I'm afraid I've never had that problem and no longer have access to any older Razr phone to guide you. I suggest going to XDA for assistance unless someone else here can help. – acejavelin Apr 17 '16 at 2:15

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.