0

I have rooted my Zenfone 2 ZE551ML using a method which permanently replaces recovery (I didn't realize it back then). Can I unbrick it using only fastboot? I can't use adb, as I can't open recovery. I basically need a fastboot adb sideload alternative for flashing the entire firmware/ROM. I tried to flash every single part (except for the system.img, which I couldn't flash) of the firmware using fastboot separately, but it didn't work.

  • Why don't you search for an appropriate recovery, and flash it with fastboot first? – Death Mask Salesman Apr 17 '16 at 1:16
  • You mean, to flash a recovery using fastboot? Didn't work. – Samuel Shifterovich Apr 17 '16 at 12:16
  • I see. I think that it'll be better to summon @Firelord. He's the fastboot expert, after all. – Death Mask Salesman Apr 17 '16 at 13:23
  • Thanks. I don't really know the experts here, yet. – Samuel Shifterovich Apr 17 '16 at 13:38
  • Oh @firelord ! We have some presents! In the form of fastboot based problems! – Dan Brown Apr 17 '16 at 19:57
0

You can flash a new recovery image with fastboot.
The command is: fastboot flash recovery recovery.img where 'recovery.img' is the name of the image.

If you enter fasboot on the command line with no options or parameters you will see the usage, which is: fastboot flash [partition] [filename]

  • Flashing a new recovery didn't help. Neither stock nor twrp worked. – Samuel Shifterovich May 3 '16 at 19:46
  • Could you please elaborate? Did you receive an error? Was there any output at all? – Dominic May 3 '16 at 22:50
  • Stock: Couldn't get over that button combination protection thing TWRP: When I opened recovery, it rebooted. – Samuel Shifterovich May 5 '16 at 17:41

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.