So, I got a "little" problem, it started a few days ago, I woke up and my device was overheated and stuck in the bootlogo, I went to the Philz Recovery but it started with an startup error about the Cache and that it couldn't load the files there, I try to flash another ROM to solve the problem but it say it couldn't mount Data, Cache, System and neither internal storage (emmc), I tried to mount them manually but it was worthless, then I flashed the stock ROM to the device with SP Flash Tools and didn't help, piranha didn't work either, I can start the recovery and fastboot but nothing else, I flashed TWRP recovery but it can't mount any of the internal storage partitions and here is some log I get from it:

mounting /dev/blck/mmcblk0p4 on /system failed: invalid argument mounting /emmc on vfat failed: no such file or directory mounting /data on ext4 failed: no such file or directory mounting /cache on ext4 failed: no such file or directory can't find /storage in /etc/fstab

This is the log when I try to do anything

E:No valid storage partitions found for mtp

E:Unable to mount "/system"
E:Unable to mount "/cache"
E:Unable to mount "/data"
E:Unable to mount "/emmc"
E:Unable to mount storage
E:Unable to recreate and-sec folder

I don't know what to do now, and I don't know about ADB, I don't have internet connection so I can't research too much, the only thing I found is dead forums of old android versions or samsung devices with ODIN solutions

Also, in TWRP it say this about cache and data:

Mount Point: /data (/cache)
Currently file system: ext4
Removable: No
Size: 0MB
Used: 0MB
Free: 0MB
Backup Size: 0MB

The phone storage only changes on: Current file system: vfat And the System it's ext4 and it's supossed to be present but is the same as the other partitions

I have tried a few things as repairing partitions from TWRP recovery but it doesn't work, even formating mmcblk0 give me an error of permission denied and it don't get fixed with fix permissions option in the recovery

That's all the log I can give to you, I know it can comeback to life and that it's not too late, anything I can do I'll do it to save my device as is the first I had and the one who teach me "all I know" about android

  • Reflash Your rom and check if working.
    – looper
    Dec 12, 2016 at 21:11
  • Reflash didn't help, I've tried several times and the partitions remains blocked. Also it's a Lanix S130, it's MTK6572 and don't know what else to say about it.
    – Agbaroth
    Dec 13, 2016 at 22:32

1 Answer 1


You can try to format your data and system partitions using TWRP. First, boot to TWRP and enter the wipe menu.

  • Then go to Advanced Wipe.
  • Select the partitions you want to repair say data.
  • Select the Repair or change file system tab.
  • Select change file system.

Note your file system. Mine is ext4

  • Select F2FS and swipe to change.
  • Again select ext4 (original) and swipe to change.

Repeat this process for other partitions.

  • This did not work for me (maybe also not for the OP?). I guess the issue is that the mount points are reported as "Present:No".
    – Marcel
    Jun 5, 2019 at 22:14

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .