0

I have an Asterisk server configured at home. It works well, and I am able to make calls to other devices internally over LAN or Wi-Fi - as well as outbound to a VoIP provider. I use CSipSimple as the client on Android (and Jitsi on my Ubuntu laptop).

I have also configured an OpenVPN server, which is also working as expected for both Ubuntu and Android devices. I can ping, ssh, etc across it.

I want to be able to make a call to a LAN or Wi-Fi client at home, over the OpenVPN connection from my Android phone using CSipSimple (I haven't allowed Asterisk clients to register from the Internet, only from the LAN subnet).

CSipSimple is able to register and make calls - but I cannot hear any incoming audio on my phone. The call info shows no packets coming in. Calls over OpenVPN using Jitsi on Ubuntu work properly, but CSipSimple on Android does not work.

1

The audio cannot be heard because CSipSimple by default advertises the Internet-facing IP address of the phone, not the OpenVPN address. This means the control messages get through (hence one can make calls), but the audio stream is routed out through the Internet and not over the VPN.


Change to Expert mode

To change this, the CSipSimple account "wizard" needs to be changed to "Expert". Assuming you already have the account registered, long-press on the account in the CSipSimple account manager view, and press "Choose Wizard". Then select "Expert" from the "Generic wizards" option.

Change NAT settings

Long-press again on the account name, and select "Modify Account" - there will be many more options than with the basic wizard.

Under the "NAT Traversal" section of the settings, enable "Allow SDP NAT rewrite" - this will tell CSipSimple to use the same address it uses for the control messages and for the audio stream.


Note: this assumes that you are able to place calls, but cannot hear the audio. If you cannot register to Asterisk at all (or whichever SIP server you are using), then it is likely that the VPN is not correctly configured.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.