0

I've had trouble connecting my android (The Nextbit Robin) to my computer. I am pretty sure it's an Android 6.0 issue. I have been able to get it to work by enabling USB debugging and selecting MTP on USB configuration. However when I tried to do that again it just selected 'Charging only', even when selecting any other setting. I clueless as to what to do. Does anyone know how to fix this? By the way, I should mention that I am using android file transfer.

Thanks.

  • Let me see what I can find out. I have a S7 Edge on 6.0.1 and noticed similar behavior on my iMac. I haven't approached it again. Rick – rickinsav Apr 18 '16 at 22:02
  • I found the problem. The issue was with my computer. – yDaniel98 Apr 21 '16 at 0:50
  • However, I still can't connect it to my computer. Any ideas? – yDaniel98 Apr 21 '16 at 3:43
0

I should note that I have no idea why this worked, but it did.

I made a partition in my computer's memory. Then I installed a separate version of OSX. When I booted to that partition the Robin connected flawlessly. I thought that it would only work in the partition I created, however, when I booted back to the default partition, the Robin connected.

For perspective, here is a list of the things I tried before I got it to work:

  • Fast booting the Robin.
  • Rebooting the Robin.
  • Wiping the cache of the Robin.
  • Restarting my computer.
  • Clearing the SMC and NVRAM of the computer.
  • Turning on usb debugging.
  • Switching between usb modes in developer options.
  • Probing the usb ports in my computer (software).
  • Disconnecting and connecting the usb several times out of pure frustration.
  • Connecting the Robin to another computer (it connected).
  • Uninstalling Android file transfer and reinstalling it.

Hopefully one of these things will work, if someone has this problem in the future.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.