2

I plugged in my headphones this morning, which were working fine yesterday, and went to try and watch a video only for there to be no sound.

But all notifications and click events seem to be making sound as usual. And only certain apps seem to be not making sound.

Thinking it was possibly a bug in YouTube, I tried running other apps:

  • Spotify: no sound

  • Google calendar notification :full sound

  • Hearthstone, a game : no sound

  • Analogue Synthesiser emulator: full sound

  • ZType, a game: full sound

  • Shadowrun returns, a game: no sound

  • BBC iPlayer: no sound

  • Sony Xperia Podcast app: no sound

  • Pointless, a game: no sound.

I've yet to test with other headphones. But have tried a restart and tried double checking the volume control advanced settings.

Any idea what the reason is?

If it was all sounds or only loud sounds it would be simple, but it's not, which is what confuses me.

further testing

After I got to a desktop PC did some further tests:

  • tested same sources with a different set of headphones, same result.
  • tested the original set on the desktop PC, produce sound from all sources no problem.
  • Set phone to safe mode to see if it would be an app which has a damaging bug after update (as I've set my phone to update when on wifi and charging, so it is plausible) the behaviour was the same.
  • Bee, the Headphones I currently use have never been detected by smart connect, I think it's because they have a detachable cable, They're a set of shure headphones. – GeorgeWL Apr 19 '16 at 15:38
  • Well, the phone is still under warranty (but not insured) do you believe this could be an issue that is viable for sending it back to Sony at no extra cost? – GeorgeWL Apr 19 '16 at 16:14
  • I never dealt with Sony but yes IMO, this warrants exchange. For starters you could post on their support site and if it helps, it could save you the trouble of sending back – beeshyams Apr 19 '16 at 16:18
  • Soundabout didn't have any effect – GeorgeWL Apr 19 '16 at 17:10
  • I had a problem with headsets and Skype on an Xperia z3 a while back. And then I found out order matters: the headphone needed to be plugged in before opening the app. Another potential cause: SONY tries to be clever and detect different headsets. In the sound settings, there is an option to select "generic headset" (don't know for the Z5, but probably similar) – stefan Apr 21 '16 at 7:52
2

Use Soundabout app. That will temporary fix the problem. Marshmallow created issue in some phones as their earphones don't work properly.

Link https://play.google.com/store/apps/details?id=com.woodslink.android.wiredheadphoneroutingfix

This app solved the very same problem in my Xperia Z2. Select "Media Audio as Wired Headphones" when using headphones. I think its software related problem because it appeared after Marshmallow update.

  • Self solved, but yeah, it's a hardware issue, I need to send it back. But it seemed to work after a restore to factory defaults. – GeorgeWL Aug 3 '16 at 23:13
  • Well it might be hardware and software – GeorgeWL Aug 3 '16 at 23:14

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.