4

After around 5-6 hours this morning/afternoon, I've officially given up on fixing this on my own, and I've all but accepted my device to be an expensive paperweight.

I decided to make one last attempt at saving it by posting for help.

Problem: My phone has a feature called "FRP" (Factory Restore Protection), which is tied to one's Google account. Basically, if you have a Google Account on the phone, it locks the phone to any custom binary/custom OS/whatever.

Once I realized this, in order to root my phone, I went in and removed my Google accounts. Sure enough, this disabled the FRP Lock, and I was able to root my device.

After rooting my device, I re-added my Google accounts and went about my business for the next couple of weeks or so.

Just this morning, my phone was having issues charging, so I decided it'd be a good idea to give my phone a reboot. Big problem. It turns out I simply haven't ever turned off my phone since I rooted it. On top of that, I didn't think the FRP Lock would apply to booting the phone, I thought it only affected flashing new firmware. I was wrong.

After my phone turned off, red text appears at the top of the screen: "Custom binary blocked by FRP Lock".

This is the problem. It simply cannot boot. Because it cannot boot, I cannot remove the Google accounts to disable the lock and resolve the problem. Because the lock can't be disabled, I can't flash the phone's original firmware, because FRP Lock will stop anything and everything I try to do.

tl;dr: Soft bricked phone due to FRP Lock. Not able to restore original firmware, factory restore, or boot into phone's operating system.

Important: The phone turns on, and I have access to the recovery menu as well as "Download Mode"

What I have tried:

  • Factory restoring through the recovery menu, doesn't have any effect
  • Flashing stock firmware through Odin (Nand write failure)
  • Flashing a custom recovery environment (TWRP) through Odin (FRP Lock blocked this flash)
  • ADB and Fastboot cannot recognize the device
  • Tried to use Kies 3 and Smart Switch to "re-initialize" my OS or something. Both failed, saying that my phone wasn't compatible, and that my serial number was invalid (it was, in fact, correct)

The point here is that I've done everything, and literally everything has failed for one reason or another.

I feel like it is a possibility that if I attempted another stock ROM, then I might be able to avoid the Nand Write Failure. But again, I don't know.

migrated from superuser.com Apr 22 '16 at 3:02

This question came from our site for computer enthusiasts and power users.

  • forum.xda-developers.com/sprint-galaxy-s6/help/… did you try what this forum suggested? – DrZoo Apr 22 '16 at 2:23
  • I bumped into that post while I was searching wildly for a solution earlier. I'm currently downloading the latest stock firmware at the moment, 6.0.1. I'll see if this works in... hours, once the download is finished. – Purlek Apr 22 '16 at 2:33
2

Turns out that the stock firmware was failing to write because it was an old version, and Android doesn't like old versions, and it won't work.

I downloaded the most recent firmware (6.0.1) overnight, and sure enough, it flashed, and my phone is now functioning again.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.