1

I recently loaded Cyanogenmod 13 on my nexus 4. Prior to flashing, I did a full adb backup and an app data backup for com.king.candycrushsaga. The only thing that seems to need restoring is the candycrush data, but adb restore doesn't seem to do the job. It simply creates an empty folder in /sdcard/Android/data.

I used the abe.jar expander app to extract the .ab contents to a backup.tar file to see what was really in the backup, and there's an extensive set of files there, but they are all relative to apps/com.king.candycrushsaga. I can't find any apps/com... structure on my phone now. And since there's no 'data' component to file paths in the adb backup, it would seem that Android 6 stores app data in a different location than 5.1 did. Is that true? And if so, can I just use my .tar backup to restore the data to the correct location? Or rebuild the .ab with a new top level directory?

  • 1
    Unless your device is rooted, you won't be able to access that "apps" folder (which resides inside /data on your device; usually app data are stored inside the /data/data/<package_name> directory, which normally is only accessible to the app itself (and of course root)). – Izzy Apr 24 '16 at 17:24
  • Thanks. I didn't know you needed root for adb restore to work. I just enabled root in Estrongs file manager, and can now see /data/data. I'll retry my restore later. – littlenoodles Apr 24 '16 at 19:15
  • You don't need root for adb restore to work – but you need root to manually check/access directories below /data ;) – Izzy Apr 24 '16 at 19:17
  • Oh. Hey, wait. Restore did work the last time I tried it - before granting it root. I swear I had tried it several times before and it didn't. Hmmm. I hope I'm not so stupid as to not only restored before the app was loaded. I do think I did that once, but tried again after loading the app. Anyway, thanks for putting up with me. Nice to know ADV doesn't need root. – littlenoodles Apr 24 '16 at 19:29
0

ADB backups usually do not contain system apps, unless explicitly specified by you while performing the backup process. If this is the case, you can certainly restore safely without any problem. But some apps may be incompatible with 6.0 as such. So they may not work after the restore.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.