2

I'm trying to get any folder on the internal storage of a HTC M7 to be mounted via sshfs to a folder on my NAS. The goal would be to have for example the /sdcard/My Documents/My Recordings folder setup like this so it has almost unlimited storage. I've installed EasySSHFS and connected via adb shell. In /data/data/ru.nsu.bobrofon.easysshfs/files are the ssh and sshfs binaries. I exported this folder to $PATH and started trying.

I tried mounting through the following symlinks:

/sdcard 
/storage/emulated/0
/storage/emulated/legacy
/mnt/shell/emulated/0
/mnt/shell/emulated/legacy

always trying to get to the My Documents/My Recordings folder. Depending on whether or not I used su some folder paths worked others don't. But even if they where mounted the app (I tried with Smart Voice Recorder as it allows you to set the path of your recordings, HTC's builtin Voice Recorder doesn't) wouldn't place its files onto the NAS but instead into the folder. Using a different path I was able to see the files locally. Without su though I can't sshfs because of a permission problem with /dev/fuse. I think the problem must be with the way android mounts the sdcard (fuse) but I can't figure out what exactly it is. I also tried mounting something not on the sdcard and symlinking to it but that didn't work either. Im suspecting the fuse mount to prohibit that as well.

Any Ideas?

1

I had to disable "Mount namespace separation" in SuperSU to get this to work.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.