With my S4 running CM13 I'm now getting this error,

Unfortunately, Setup Wizard has stopped.

How do I resolve it?

  • If you're going to downvote the question just tell me why. I had already found the problem when I decided to self-answer here and contribute to the question base. – Evan Carroll Apr 26 '16 at 13:19
  • Follow my answer <a href="android.stackexchange.com/questions/167055/…> to ger rid of the Setup Wizard directly. – iBug Jan 21 '17 at 3:50
  • You can follow my answer here to get rid of the Setup Wizard directly. – iBug Jan 21 '17 at 3:54

Here is a method that you can do without whiping,

  1. Boot into TWRP Recovery
  2. Mount System ( Mount → check System )
  3. Advanced → File Manager
  4. Browse to /system/priv-app/Setup-Wizard
  5. Delete it
  • Make sure to copy it to sdcard or something first though. – Ave Nov 24 '16 at 11:03

I noticed when clicking report that the issue was a permissions issue.

using adb shell dumpsys package com.google.android.setupwizard you will see two lists related to permissions, one requested permissions, and one install permissions.

Comparing these lists, there were 8 items requested, but not installed. I fixed this using:

pm grant com.google.android.setupwizard android.permission.CALL_PHONE
pm grant com.google.android.setupwizard android.permission.GET_ACCOUNTS
pm grant com.google.android.setupwizard android.permission.PROCESS_OUTGOING_CALLS
pm grant com.google.android.setupwizard android.permission.READ_CONTACTS
pm grant com.google.android.setupwizard android.permission.READ_PHONE_STATE
pm grant com.google.android.setupwizard android.permission.WRITE_CONTACTS

pm grant com.google.android.setupwizard android.permission.READ_OWNER_DATA
pm grant com.google.android.setupwizard android.permission.WRITE_OWNER_DATA

Note that the last two items gave an error message: Bad argument: java.lang.IllegalArgumentException: Unknown permission: android.permission.READ_OWNER_DATA. But ignoring those, now my phone worked again.

  • I think I have a similar issue but I cannot find dumpsys or pm from an ADB shell, do you know if they may have been removed or if I need to install something first? – Marie Jun 13 at 17:14

I tried all the solutions listed here, and in my case they didn't work. Removing the setupwizard alltogether did work, but it also broke multiuser functionality (apparently the default user gets created in the wizard, and without the user you can't create more users!). Also the home-button and square-button didn't work at all. So I decided to flash the image again and solve the problem instead of curing the symptoms.

In my case, I had to get into the settings menu and enable+connect to WiFi. Apparently the wizard "forgets" to show the connect to wifi dialog! Getting into the settings menu took a few tries, but it's absolutely doable.

Once I was connected to wifi, it worked as it should. I'm running AOSP 7.1.2 on a Nexus 7 2012.

For me this solution worked. It might be annoying as you have to do all the clicks in between the Setup Wizard error messages.

And yes, this method will work in all the versions of android (including 7.1.1-Tested)

  1. Go to Settings (from notification panel, obviously)
  2. Go to Apps
  3. Click on the 3 dots in upper right corner
  4. Click on Show system
  5. Scroll all the way to Setup wizard in the list of apps and click on it (Under the permission you will probably see something like No permissions)
  6. Click on Permissions
  7. Grant permissions to both Telephone and Contacts, (if there is any other like, camera, location, Grant Them All)

The error message disappeared as soon as I did this. Hope it helps ;)

  • What if notification panel doesn't come down? USB Debugging disabled... – Waldemar Wosiński Sep 2 at 21:41
  1. Make sure in Settings > Developers Options you have enabled USB Debugging (now called Android debugging) and under Root access you have selected Apps and ADB.
  2. Connect the USB cable to a computer that has adb installed and working (assuming it is available in PATH).
  3. From the terminal run:
adb root
adb shell 'pm disable com.google.android.setupwizard'

If you don't have root or if adb root fails, then you can use instead adb shell 'pm hide com.google.android.setupwizard'.

NOTE: This problem usually happens when installing a major CM update without wiping the data partition, so probably a cleaner solution would be backing up all the relevant apps, doing a clean install, installing the correct version of gapps, and then restoring your app data from backups.

  • After using adb shell 'pm disable com.google.android.setupwizard' I managed to get into the system and enter my google account information, then I enabled it from 'adb shell 'pm enable com.google.android.setupwizard' to complete the setup. – Muaad ElSharif Jan 8 at 15:51

protected by Community Jul 20 '17 at 19:46

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.