1

A few weeks ago I bought an Android phone in India, popped in an Indian SIM card, plugged the phone into my laptop over USB, turned on USB Tethering, and connected to the internet immediately. It worked amazingly well out of the box!

This week, I'm back in Europe, and the roaming costs of an Indian SIM are rather high... So, I popped in a local SIM for the country I'm in, accepted and stored the Access Point from the Configuration message the operator sent me, and the phone itself connected to the internet fine. Apps worked, browsing worked, apparently all good.

Then, I plugged my phone into my computer with a USB cable, and turned on USB tethering. My computer connected, got an IP address, and.... Nothing. No actual internet connection to go with it!

This leads me to suspect that I'm missing some sort of setup step, but I can't find any Access Point / APN settings in tethering.

What do I need to do to diagnose this issue, and get tethering working again on the new sim?

0

The issue is one of Access Points, just not one configured in the tethering settings.

The fix was to go to Settings, then More under Wireless & Networks, then Mobile networks then Access point names. Finally, edit the APN that the network configuration sent. In there, I found that the APN type was just default

It turns out that default is enough for the phone to get online, but not for tethering to work. So, I changed it to default,net,dun, as shown:

AP settings needed - click for full size

With that in place, Tethering magically started working

So, the fix was APN related, just that it isn't something (in Android 5.1 at least) that is setup in the tethering area, it's in the mobile networks area and needs the dun and net settings

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.