I got a really confusing problem at hand with my Nexus 4 right now.

When I woke up in the morning, I looked at my phones screen. Everything was looking fine (and I had about three quarters of my battery left). When I tried locking it, it didn't go black, instead it gave me the option to turn it off, as if I had pressed the button for a little longer. I thought a reboot would fix this so I turned it off.

When I tried to restart my phone, it showed the Google logo for about one or two seconds, then the screen went off again. Waited for a couple of seconds, then tried turning it on again several times, always with the same result.

I started looking the problem up online and found this (http://forums.androidcentral.com/google-nexus-4/312151-solved-nexus-4-won-t-turn-charge.html) thread. Even though it was different from my problem, I thought I could try the steps mentioned there. When I did, my screen just turned black and a red LED started flashing.

Online, I found several sources saying that a flashing red LED simply means that the battery is drained lower than 0% and it would fix itself if I let my phone charge for a couple of minutes. So far, this has showed no results. Also, I don't think that my battery is empty, since it had roughly 75% before I turned my phone off. My Nexus had some strange battery issues before (rebooting with up to 60% less battery than when it turned off), but that never happened frequently and most of the time it came from crashes from the good old camera bug or when it froze during video playback.

I'm using a Nexus 4 16GB with no root access or any other modifications. I run the latest firmware update (though I'm not sure which version number that is).


Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.