0

I disabled Phone application and set force stop in CyanogenMod 13. Now, I cannot find the phone application anymore. The phone crashes if I try to call.


How can you restore Phone Application in CM13?

5
  • You're saying it's not there when you go to Settings app -> Apps -> tap All apps and choose Disabled -> you don't get to see Phone app?
    – Firelord
    Commented Apr 29, 2016 at 18:45
  • @Firelord Yes, it is gone. Commented Apr 29, 2016 at 18:45
  • Have you tried pm enable command? It requires root access and package name.
    – Firelord
    Commented Apr 29, 2016 at 18:47
  • No. I think I have no root. Installing any new phone app crashes the phone when I try to call with it. What to do? Commented Apr 29, 2016 at 18:53
  • 1
    If you don't have root you can enable it in settings if you're using CM13. Some apps will tell you to download SU this is a mistake if you're using CM13. Commented Apr 29, 2016 at 19:23

1 Answer 1

2

It must be a problem with the ROM if it is not showing the app disabled through Settings app like this:

(Click image to enlarge)

IMG:

Anyhow, if the Settings app doesn't show it then I see no way to solve this problem without root. If the following steps do not work then your ROM is faulty because they worked for CM13-snapshot in my Nexus 6. In case you do not know, root access can be enabled in CM13 from Developer options.

A disabled app is a user specific restriction and the restriction ends up in the file /data/system/users/USER_ID/package-restrictions.xml. USER_ID for primary user (owner) is always 0.

Find the entry responsible for disabling your app using the app's package name and either remove the whole line or make tweaks there. I'm instructing with a tweak. Here's how the restriction originally looked like:

IMG

For the case in question: In the line depicting the cursor and containing the string com.android.dialer, integer to enabled represents the state of the package and enabledCaller is the caller which instructed the package to be disabled. You can either remove the whole line or change enabled=3 to enabled="1". (Source)

Do a full or soft reboot and you would find your app enabled.

The alternative method is to use a terminal emulator app or with adb shell command to execute these:

su
pm enable PACKAGE   # PACKAGE refers to package name of the app to be enabled

If you don't know the package name of your app, follow View app's full package name?

Another alternative: While I didn't try, I've full faith that Titanium Backup would offer the option to unfreeze your app. There may be other similar apps that can help you out.

If the said solutions make no effect on the app's status, ditch the ROM.

3
  • Thank you for your thorough answer! I found the app in Settings > Apps. Commented Apr 29, 2016 at 19:14
  • Did you reboot or did something else? I don't follow how you weren't able to find it earlier but can do it now.
    – Firelord
    Commented Apr 29, 2016 at 19:21
  • In the application view, I could not see it. I did not know that you have "Apps" menu inside Settings. There, I could find it. Commented Apr 29, 2016 at 19:41

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .