1

I bought a Samsung Galaxy S5 [G900H] and I installed custom rom from here to get rid of most unwanted applications and having a pure and de-bloated android on my smartphone.

After installing this rom it's working perfect except that when I install (root)firewall applications like DroidWall they do not work as expected and if I create an allow rule for an application, application could not be connected even when I set it to be allowed to use wireless/mobile data. But if select allow rule for all rooted applictaions it works fine but its useless this way.

I also tried to use unroot firewall but it is giving this error message "The VPN is not supported by your device."

I also checked blacklist/white list mode and mode is set to whitelist only.

Does any expert know what problem should be and is it required for me to install other roms to cross over this problem?


Update:

Now I restored my android to its official stock version (I had created a full backup before installing a new custom rom) and tested both DroidWall and AFWall+ and the problem still persists. Seems this problem is a bug coming from Samsungs TouchWiz.

  • 3
    DroidWall is ancient. Please switch to its successor AFWall+ or some other regularly updated firewall app. – Firelord May 2 '16 at 18:26
  • @Firelord Ok I'll check it now. – Mojtaba Rezaeian May 2 '16 at 18:34
  • @Firelord I tried AFWall+ it is better than DroidWall but it is not working as well. It works for some applications while not working for other. Very strange. – Mojtaba Rezaeian May 2 '16 at 19:06
2

I finally solved this problem in the case of very strange and share my experience here; maybe useful for someone with same or similar problem:

After a few days struggling with this, Using AFWall+ enabled on my restored official stock android, I‌ tried to change Wifi settings (got to wifi->advanced->[disabled most of Samsung/Google features being there] plus using manual IP[192.168.1.129] and DNS[192.168.1.1 - 192.168.1.2]) and finally I found out the problem has gone away! So after that I tried to test which option was causing the problem (trying to remember restore my previous choices) to restate the problem but the problem did not restate and everything is well till now.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.