4

A friend borrowed my phone when they forgot theirs. They had to log into their Gmail to get their contacts to find where they left the phone. When they added their account, it was synced to my phone.

I have deleted the account, but their contacts are still on the phone. I have tried to clear the cache and re-synced the account.

I do not want to do a factory reset unless that is the last resort. Any suggestions or ideas?

  • can't you delete the contacts normally? – Joe May 4 '16 at 19:14
  • No, I get something saying that I cannot delete contacts from read-only accounts just hide them in my contacts list. – Norman H May 5 '16 at 13:46
3

Removing the Google account should have invariably deleted the contacts linked to that account, from your phone.

If not, go to Contacts, choose "Contacts to display" and select the Google account of your friend. This should bring up only those 'unwanted' contacts. Select all and delete. In case if the account does not show up in "Contacts to display" then you can try adding the account once again. But this may delete all the contacts from your friend's Google account. Make sure to ask him to take a backup / export all contacts, in case if he needs to restore in his Google.

Hope this helps.

1

I finally was able to get rid of the unwanted contacts. What I had to do was have my friend add their e-mail back onto my phone. I then turned off the Sync for this phone. After that I deleted all the unwanted numbers and contacts. Once that was done I removed the e-mail account. I then forced a Sync and then restarted my phone.

  • Can you clarify this? I have the same problem. One main account (must sync contacts) two secondary accounts (do not sync) how do I get rid of these? – Riccardo Nov 24 '17 at 10:00
0

This is lifted from jpolito's 2017-03-15 reply here. It is the only thing trick has worked for me - not wanting to risk deletion of contacts for the second account.

  1. Phone Setting> Accounts> Google> Select your SECOND email account> "Remove account" 
  2. Phone Settings> Accounts > Turn Off Auto Sync
  3. Re-establish account.
  4. Turn on Airplane Mode
  5. Phone Settings> Accounts > Turn On Auto Sync (Without autosync turned on, there is no option in manage accounts to uncheck syncs)
  6. Open the Gmail app.
  7. On the top left, click on the 'Menu' icon.
  8. Click on the dropdown next to your email address.
  9. Choose 'Manage Accounts'.
  10. Select 'Google' and select your SECOND account.
  11. Uncheck the 'Contacts' checkbox and all other unwanted information.
  12. Turn off Airplane Mode
0

1) go to https://contacts.google.com/ 2) in the left side bar press more 3) Press undo changes enter image description here

Then it will open a dialogue where you can choose when to reset it by. I personally like choosing custom and then you can set it exactly. enter image description here

I was able to do this several times and I even accidentally deleted all the synced contacts but still this feature helped get it back for me.

protected by Community May 29 '18 at 15:36

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.