1

I am trying to use a Samsung Galaxy S6 Edge for debugging an android app. I've downloaded and installed the Samsung USB driver but when the device appears in android studio it says the device is unauthorised. I've got my phone connected in transfer image files mode (PTP mode). I've tried turning USB debugging on and off and after reading other forums it says I should get an authorise pc message on my phone but nothing appears.

Any idea how to get it working?

  • 1
    If you have found your answer, please add it as an answer below and accept in, instead of editing it into your question. – Michelfrancis Bustillos May 10 '16 at 13:55
  • Do you've an option Revoke USB debugging authorizations under Developer options? Unplug the device from PC, use that option and now plug it. Restart adb server using adb kill-server followed by adb start-server. Type adb shell. If no popup shows up then remove adb keys stored in your PC. If the problem still persist then I would consider Benjamin H.'s advice. – Firelord May 10 '16 at 14:44
3

By deleting the adbkeys file found in C:\Users[Username].android folder the permission dialog appeared on my device.

1

Like you already said:

Unauthorized means that your is not trusting your computer. This is because after activating USB-Debugging and connecting your phone to your PC, there should be a popup asking you if you want to trust this PC, which you have to agree (permanently).

The issue now is that you do not get the popup. I also had this issue (on another device) and installing other USB drivers solved the problem. Maybe you try the official standard Android USB driver. If this does not work too, try other drivers or if possible try it on another PC. Also try to disable and re-enable USB-Debugging (and reconnect USB) after installing new driver.

Before installing new drivers, make sure to remove all of the old broken drivers with USBDeview (Download at the end of page). You need to unzip it and !run the program as administrator. Then it creates a list of all USB drivers installed on your PCs (pay attention, as there are also drivers for other USB devices like printers or USB sticks). Select all unwanted old Android USB drivers by holding CTRL and selecting one entry after another. If you have selected everything, release CTRL. Then click on the remove-icon or right click on any entry and click remove. Then the installed drivers should be cleared and you can install the new one.

1

I had the same problem because my C:\Users\--username--\.android folder was empty and readonly (because trying to cleanup C: and migrating to D: drive). Allowing to write to that folder and running adb server put the adbkeys files in and the permission dialog appeared on my device.

0

I had the same problem and deleting the adbkeys files in C:\Users[username].android folder re-enabled the authorization dialog. Good hygiene recommendation: Copy those files and store them somewhere else prior to deleting them so you can more easily restore them if this is not your solution.

0

I tried all this and the only thing that worked for my Lenovo tablet was to switch it to PTP mode from MTP.

  • Tried all what? – ale Jul 15 at 13:09

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.