0

I have a rooted Samsung Galaxy Note 3. There's no Google Play services on it, and so no apps that require Google can work, and Snapchat is one of them. I tried downloading the Google Play services apk, as well as Google Play Store, but it gives me an error message that says "Google play services has stopped responding." In addition, I've tried using Casper for Snapchat and I got banned from my account for a day. Is there a different, simple way to get Snapchat or Google Play Store/services?

In addition, several apps don't work like YouNow and Atomas. It just says that it stopped responding. Is there a way around this too?

1

you should download the old version of snapchat, this doesn't require play service. link: https://snapchat.en.uptodown.com/android/download/46825 you should sign in or sign up and after, update it. and it will work perfect. you can also try this with some apps that requires google play service. just download the first version on Uptodown store and update it after.

0

When installing the Google Services Framework, the best way is to flash a GApps package via recovery (to properly write to /system). You can find the flashable package for your Android version at OpenGapps.

In addition, some apps try to detect if your device is factory modified (eg. rooted) and may prevent you from using its services by stopping the process if root is detected. One app that may help you work around this issue is RootCloak, though you will need to install the Xposed Installer app and framework.

Note: Some apps also try to detect the installation of this app, so be wary when you are using it.

-1

As you are rooted try installing the Xposed framework installer. This allows you to apply patches to the device such as one for removing the Google play services error message. Xposed may brick your device so ensure it's compatible.

To install the module install this app after installing Xposed. It will require you to reboot.

  • The module just removes the warning; apps that would not open or would force close without GSF will still behave the same way. – Andy Yan Mar 6 '17 at 8:17
  • And an extra notice: devices from Samsung, Xiaomi, etc. might need special versions of Xposed, depending on the ROM loaded on them. – Andy Yan Mar 6 '17 at 8:18

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.